[SOLVED] Weird noises while trying to take off stock AMD cooler.

Oct 23, 2020
1
0
10
0
I really need help, I’m trying to put in a new AIO for my prebuilt Pc. I’m trying to unscrew the big black 4 screws on the stock cooler. It’s making a weird clicking noise while I’m unscrewing. No, I am not tightening it, I made sure I’m turning it left, not right.
 

Prad_Bitt

Prominent
Jul 4, 2020
577
105
590
21
I really need help, I’m trying to put in a new AIO for my prebuilt Pc. I’m trying to unscrew the big black 4 screws on the stock cooler. It’s making a weird clicking noise while I’m unscrewing. No, I am not tightening it, I made sure I’m turning it left, not right.
It's probably the tight springs that are on those screws, don't worry just be gentle. 50% on each X pattern then 100% each X pattern and you're good to go. Rotate the cooler left and right slowly to break the thermal paste while pulling gently
 

Prad_Bitt

Prominent
Jul 4, 2020
577
105
590
21
I really need help, I’m trying to put in a new AIO for my prebuilt Pc. I’m trying to unscrew the big black 4 screws on the stock cooler. It’s making a weird clicking noise while I’m unscrewing. No, I am not tightening it, I made sure I’m turning it left, not right.
It's probably the tight springs that are on those screws, don't worry just be gentle. 50% on each X pattern then 100% each X pattern and you're good to go. Rotate the cooler left and right slowly to break the thermal paste while pulling gently
 

ASK THE COMMUNITY

TRENDING THREADS