Question Weird PC Freezing issue

Marcel Schollen

Distinguished
Mar 21, 2013
69
0
18,630
0
So lately my PC has been having a really weird Issue where it will randomly start freezing up. the PC is not FULLY frozen, I can still move my cursor and click on things but nothing will work properly. Even when I click Shutdown or Restart it will do nothing except for slowly shutting down all the active apps but not actually turn off the PC itself, if I logout through CTRL+ALT+DELETE it will be stuck on a log out screen loop and everything will just seem extremely laggy. When highlighting something such as hovering your mouse over an icon in the taskbar the highlight of the icon will stay stuck when I move my mouse away.. all this kind of crap, no apps will load properly, etc etc etc..

I have absolutely no idea what is causing these issues, I thought it was a memory leak at first of some sort but nothing seems to be wrong with my ram.. I don't even know if it's hardware or software related.. Does anyone happen to know what I am talking about? I have been trying to much to fix it, clean my PC, reseat all my RAM, check cables, full clean install of windows..

Please someone help me out here.

I will edit this and include a video as soon as it happens again.

Here is my specs/everything in my PC:

Hardware
  • Case - Fractal Design Define R4 Window Edition
  • CPU - Intel Core I7 4790K
  • CPU Cooler - Corsair Hydro H110i
  • Disc Drive - Liteon iHAS124
  • GPU - Asus GTX1060 Dual O3G
  • HDD - Western Digital Caviar Black 1TB
  • Media Reader - Sharkoon Media Reader 3
  • Motherboard - Gigabyte GA-Z97X-Gaming 3
  • PSU - Corsair RM650x
  • RAM - Corsair Vengeance 16GB
  • Soundcard - ASUS ROG Xonar Phoebus
  • SSD - PNY CS1311
  • USB Header Expansion - NZXT IU01
  • Wifi/Bluetooth Card - Gigabyte GC-WB867D-I
  • OS - Windows 10

    Edit:
    Here is a video of what it looks like when it happens:

    View: https://youtu.be/myznssRTHbU


    Somethings I didn't state in the video.

    Usually I can still get to the start menu and actually click shut down or restart. however it will not do anything. and normally when i do CTRL+ALT+DELETE and click any of the options other than task mngr I just get a loop of ''logging off'' screen.
 
Last edited:

Lutfij

Titan
Moderator
First make sure you're on the latest BIOS version for your motherboard. The next step is to check and see which OS version you're currently on. You might be on Windows 10 but pretty much everyone is on version 2004. The next thing to do is remove all the unnecessary hardware that isn't required for booting to OS, see if that helps.

How old is the PSU, mind you?
 

Marcel Schollen

Distinguished
Mar 21, 2013
69
0
18,630
0
First make sure you're on the latest BIOS version for your motherboard. The next step is to check and see which OS version you're currently on. You might be on Windows 10 but pretty much everyone is on version 2004. The next thing to do is remove all the unnecessary hardware that isn't required for booting to OS, see if that helps.

How old is the PSU, mind you?
My MOBO has not had a bios update since 2016 so that should be all good.
My OS is on version 10.0.19041 Build 19041
Removing the unnecessary hardware can be done but it's gonna be very hard to tell if it helps or not because the issue happens at random, sometimes not for 3 days, sometimes 3 times in one day.
My PSU is 4 years old.
 

ASK THE COMMUNITY

TRENDING THREADS