Question Weird problem with frame drop associated with refresh rate

Aug 15, 2019
1
0
10
0
I have two computers with Geforce cards attached to a Kebidu 1080p 4x1 multiviewer adapter that works well. The adapter accepts 1920x1080@60hz of input and output. However, if I set the refresh rate to 60 Hz, strange behavior happens in multiviewer output. Every x seconds, the multiviewer's output video framerate clearly drops to 30 temporarily, resuming to 60 after a while, repeating exactly as loop.

I already tried to adjust v-sync in the nvidia panel and it didn't work. Changing the input resolution does not work either. I've already changed Advanced Timing to CRT, reduced white CRT, GTF, etc. Does not work.
The only change that works is to create custom refresh rate at 59.99, 59.989, etc. Changing the refresh rate does not correct the problem, but it considerably reduces the proportion of time the output video stays at 30 fps.

Let's say x is the time at 60 fps and y is the time at 30 fps (at multiviewer output).
At 60hz, I can say that x and y are the same proportions of time. Like 20 seconds at 60 FPS and 20 seconds at 30 FPS.
If I set it at 59.99hz, x becomes 90% of the total time, and y 10%. The behavior looks like a cyclic stuttering.
I've tried several values around 59.99hz, like 59.989hz, 59.991hz, 59.988hz, 59.992hz ... The farther from 59.99hz, the greater y is relative to x.

A bizarre solution is to set the resolution to 119.98hz. The first time, I didn't think it would work, but it works! 119.98 looks like 59.99 times 2, but y becomes virtually null and the output video is all the time at 60 fps.

I don't know, but it looks something like frame skipping.

Any suggestions?
 

ASK THE COMMUNITY