Weird problem with physx in games

Trioxin

Distinguished
Mar 16, 2008
39
0
18,530
0
So, here the thing. I've noticed a weird thing in few games that I've been playing. Warhammer 40K and Witcher. Whenever the games uses the physics system I get a weird stutter. For example, I kill a mob in Witcher and their body hits the ground and they suddenly start stuttering like some sort of fps drop, not in the game, just at the object in question.

Same thing happens in Warhammer, fps is great and everything is set on high, but the moment I got those minianimations of kills the same thing happens it's like the game runs at 60fps and except that mob that runs at 15fps. It like some sort of physx slowdown. I've got i7 950 with 6gig ram and Nvidia gtx 580 (with latest drives). Any ideas?

I've also ran that fluidmark and I get really low fps in it. I know I used to get around 70fps or more and now it's 35-40.
 
yeah thats just nvidia physx it really is a gimmick best turn it off uninstall the current physix and install an older version see if that helps. nvidia are notorious for fixing 1 problem only to have another crop up...
come to think of it ati is no better.

you will be able to tell when its cocking up. npc's will fly off at mach 2 because they fell over a pebble or you will bet black anomalous stretched out polygons and other glitches.
 
Physx isn't a "gimmick" better left off. It greatly enhances what you see on the screen and makes gaming more enjoyable. You obviously have some kind of problem somewhere if you get those results with the hardware you have. ( list rest of it )

A quick trip though the device manager and/or a trip to windows update may find something helpful.

Check your nvidia control panels' settings and game panel settings. See if physx is on auto ( device/proc or card ). Check your monitors refresh rate and see if it's running at it's native resolution.
 
it is a gimmic m8. havok and other physics engines do it so much better. nvidia need to move away from there ancient instruction set. havok in the meantime is running its physics of 1 cpu yet physix needs 128 coda cores just to keep up with my 5870 or it will bottlneck it.
its still the same agia physix engine that they bought years back with a few minor tweaks to the api so it will run on the newer hardware...
this aint just my opinion its the opinion of many devs that have used it and decided to move on to a better engine.
 

Trioxin

Distinguished
Mar 16, 2008
39
0
18,530
0
But it only happens in those few games, tried Dead Space and physx works great there. Physx is set on auto, and it's the latest version. I've also got Dell U2410, but it's listed as generic PnP Monitor. Haven't installed drivers for it. Could there be a problem?
 
no m8. its unlikely the monitor is affecting it. the twitching corpses like you see in the fountain in dawn of the dead is a byproduct of the physics engine... its trying to map the body to the environment but it cant so it keeps trying. if you physx off the body will slump and stay put.
as for your fluid mark. try an older set of physx drivers and see what happens.
 

Trioxin

Distinguished
Mar 16, 2008
39
0
18,530
0


They do it, they fall down in slump and stay put, but while they're falling down they fall in low fps i guess, stutterish like.
 

Trioxin

Distinguished
Mar 16, 2008
39
0
18,530
0
Sorry for slow response. Nope, not running a separate card. But I've noticed in device manager that I have four "High Definition Audio Device" and "Realtek Audio Device".
 

ASK THE COMMUNITY