Question Weird sound from the laptop when gpu fan is plugged inn

Jul 19, 2020
4
0
10
0
I have an Asus fx504g3 laptop, about a year ago my laptop was not turning on so I gave it to the services center and they said "motherboard issues " and they took about a month to return my laptop. Now recently it is not turning back on again, so again I gave it to the service center and after a week they told me "motherboard problem " and it would coast me 450$ to fix it.i took it back home and guess what! it turned back on again and the GPU fan was not working .i decided to open my laptop and I found my GPU fan was not connected and my wifi card's (a white thin colored wire) wire was cut, I connected my GPU fan and turned on my system and I got a long continuous beep from the system and the fan did not rotate at all.Can someone please tell me what is the issues here and the solution to it. Here a link to the photo https://ibb.co/gyRbx5T

Thank you
 

hang-the-9

Titan
Moderator
Try buying another fan, although from the looks of things whoever looked at the system may have damaged the system or that was the issue in the first place that the fan header did not work. Having a wire actually cut is a bit odd, that may have been done by whoever was checking the laptop. You said this happened a year ago? Was the laptop in warranty back when you had them look at it?
 
Jul 19, 2020
4
0
10
0
Try buying another fan, although from the looks of things whoever looked at the system may have damaged the system or that was the issue in the first place that the fan header did not work. Having a wire actually cut is a bit odd, that may have been done by whoever was checking the laptop. You said this happened a year ago? Was the laptop in warranty back when you had them look at it?
yes, it had a warranty back then. when it happened for the second time the warranty had expired so I decided to open it up, I'll try swapping the GPU fan with the CPU fan and I'll let u guys know the outcome
 
Last edited:
Jul 19, 2020
4
0
10
0
Try buying another fan, although from the looks of things whoever looked at the system may have damaged the system or that was the issue in the first place that the fan header did not work. Having a wire actually cut is a bit odd, that may have been done by whoever was checking the laptop. You said this happened a year ago? Was the laptop in warranty back when you had them look at it?
btw I live near the beach, so does humidity has to do something with this?
 
Jul 19, 2020
4
0
10
0
Environment can cause issues, beach areas are particularly bad not just humidity but the salt air and moisture can corrode equipment. Does the laptop show any type of odd wear or deposits on it, white or green areas that look like dust or mold?
nope , it looks normal
 

ASK THE COMMUNITY

TRENDING THREADS