Question Weird SSL/DNS error, I'm lost...

Sep 24, 2020
2
0
10
0
I have an issue with an SSL certificate in one of the sites that I’ve built in the past months, which is https://andreascaffardi.com

The error is the following: NET::ERR_CERT_COMMON_NAME_INVALID

Needless to say, I’ve tried all the possible fixes and nothing works.
Here’s where the things get spicy...

So, I only get the problem when I’m attached to the WI-FI, I’ve tried using mobile data and everything works fine! I probably have to mention that I have two different internet providers, Vodafone for my phone and TIM as home internet.

Still, even with TIM I only get the problem on this specific site, and none of the sites that I’ve build and which has the same exact SSL installed (Let's Encrypt Authority X3).

With Opera, I’ve solved using DNS-over-HTTPS instead of the system’s DNS settings.
I have 0 knowledge in this area, but this led me to manually change my DNS settings on both my MacBook and mobile phone (to 8.8.8.8 and 8.8.4.4).

This worked and now I can safely visit the site, but, still, the problem is alive and well.
This is pretty confusing to me because I don’t know if the problem is caused by my internet provider, by the site hosting company, or both. Or maybe by some misconfiguration too.

Maybe I have to do something on the site’s DNS Zone Editor?

Here’s some photos: the certificate that shows up normally ( View: https://imgur.com/a/z6uarH7
) vs the certificate that shows up when I’m visiting the site using my WI-FI and a default DNS configuration ( View: https://imgur.com/a/tBJptV2
).

Thanks to everyone that will try to help!
 

DeauteratedDog

Honorable
Dec 11, 2013
712
88
11,440
103
I would talk to my ISP - it is probably nothing sinister. I sometimes get my ISPs cert for a minute or two right after my modem reboots, or maybe they think the site is somehow 'bad' and they are trying to protect you.

I most commonly see this in K-12 schools who really are doing man-in-the-middle attacks because they are required to monitor the student's traffic.

By the way, I get the correct cert when I access the site.
 
Reactions: 0originale0

ASK THE COMMUNITY

TRENDING THREADS