Question Weird stuff happening to pc (Display turns off after a while, time varies)

Alberto Bj

Honorable
Oct 16, 2015
225
0
10,690
1
So a weird thing happened to my PC lately.

At first, my PC froze, (literally locked) so I forced restarted it.

Now my PC goes into boot for 1 second to 2 seconds, turns of, and repeats (doesn't POST, doesn't BIOS) it just goes on and off and on for an interval of 1 - 2 seconds. (no beeping from the motherboard as well)

So i checked the RAM, turns out it was a RAM issue since I cleaned, swapped both of them, sometimes my PC goes to post / OS when I remove 1 stick of ram or use just 1 stick (doesn' t matter which slot)

So I cleaned my RAM stick with the eraser method, with enough cleaning, my PC is up again

So I played a game for a while (particullarly Lost ark) (there are no other complicated softwares/ running / softwares installed) the only software that is always running in my pc is MSI afterburner / particullarly RivaTuner to set up custom fan curves and for me to monitor my temps while gaming


After playing for a while, my PC (particularly, the display) just went black, I don't know if it was the display because the PC was still running (all fans spinning) but I couldn't hear the windows sounds if I tried to click on something or type something (the sound that windows makes when u click or press on your keyboard when ure on the desktop). After that, I restarted my pc, BIOS and POST was good, only up to the part where my windows 10 account was being shown and loading, it loaded the desktop for a bit (1-5 secs) but after that, the display went off again. (PC still running, display, pitch black, DVI disconnected, as my monitor says).

After the third or second try, I am here now, the display haven't went off for about 15-20 minutes as I was able to type this

My temperatures are all good (GPU fan is new, repasted it) as well as CPU temps

I tried running sfc/scannow and they said they found corrupt OS files and fixed it (I can give you guys the log file if u want)

But I haven't checked anything from the event viewer cause I am not an expert in navigating that.

I also have the video of what I was talking abt (how the display goes black)

For now I will try playing again, but without MSI afterburner / rivatuner running. I don't know if it was the one causing the problems but I have been using it 4-6 months ago when I did a fresh install of my OS

PC Specs
i5 4570s
ram 16gb HyperX Fury 1866mhz (8x2) dual channel ddr3
ASUS H81M-D
GTX 1060 3gb
Windows 10 (freshly installed for about 4-6 months ago, since i encountered VIDEO_TDR bluescreen, haven't happened since then).
ADATA SP 550 SSD
Nvidia Driver: Latest one (the one that had the title update for spiderman)
 

ASK THE COMMUNITY