Question Weird system hangups/freezes ?

Sep 13, 2021
1
0
10
0
CPU: Ryzen 5 2600x
PSU: Thermaltake Toughpower GF1 650w (3 years old)
GPU: 3070 ti (brand new)
MoBo: MSI B450 Tomahawk
RAM: Corsair DDR4 8gbx2

At the start, I had an old RX480 8gb, on certain games, the screen would go black, the fans would still be spinning (not the GPU's), and I would have to press the reset button (holding down the power button did nothing).
System would reset, the Led of "GPU" on the MoBo would be lit up, nothing would happen, no screen signal.
Another reset fixed it.
I always had those issues but only with certain games, problem was, even relatively intensive games would not cause the problem at all, nor even after 4-5 hours. Apex would be fine. Chess Ultra would crash the system that way every 10 minutes, more or less.

I changed GPU to a GTX1060, also changed RAM.
Updated BIOS, audio drivers.
Problems kinda disappeared.
I upgraded to a RTX 3070 ti. Tried Streaming+Gaming, PC crashed in like 5mins, only this time it just turned off. Pressed the power button, turned back on.

Tought it might be the PSU but I wanted to test it again, played the same game again, after 1 hour, without streaming, PC turned off. This time I had to switch the psu off then back on otherwise the power button would not respond.
Tought about removing dust. I did. I also checked the cables on the MoBo, everything seemed fine.
Played APEX for some hours, all went fine.

Now, cue to me, playing again. This time CPU usage got 20-25% tops, GPU 80%, pc turns off after 50mins. But this time, this time the fans would spin (not the GPU's), everything would be lit, screen would be black, power button did nothing. Restarted, Mobo had CPU debug LED on.
Tried again, same game, 10mins, same crash, same problem.

Is it really the PSU? 650W should be kinda enough? Why very intensive games like APEX don't crash for hours but certain games do? Keeping in mind that I usually play games that barely use over 60-70% GPU.
Is it the MoBo? Why did this problem get solved then mutated into something else then mutated again into the old one?

Temps NEVER go higher than 75-79 Celsius MAX on CPU and roughly the same on GPU.

If it's worth mentioning, it has been a while since I formatted the SSD (I installed everything when I built the PC roughly 3 years ago).
Older component active at the moment is probably the SSD (A 5-7 years old samsung I can't remember when I bought it).

I've tried running Heaven's for 10-15mins and everything was fine. Tried stressing the CPU for 20-25mins, everything was fine.
 
Last edited:
Try these:
  • Disconnect from internet
  • Uninstall gpu driver using DDU (clean and do not restart, uninstall both nvidia and radeon if it's still there).
  • Uninstall all the processors on device manager (should be 12 on yours) like this:
  • Restart the pc to bios, and update to the latest bios again, then go to bios again after update and load default or optimized settings.

  • boot up to windows and install the latest AMD Chipset driver, reboot and connect to internet.

  • Install the latest nvidia driver.

    *do this all offline until reboot after installing amd chipset driver, also you may reboot to bios after all of this to set the XMP (and manual tune the timing if you want), make sure your ram is on slot 2 and 4. Download needed files (highlighted word) before doing step 1, do the step by orders.

  • And check windows update (and optional updates) if there is any. Also enable Hardware Accelerated Graphics Scheduling in graphics settings like this and reboot:
Make sure the psu connected to the gpu is 1 pcie cable per 1 slot (use main cable, not the branches/split) like this:
 

ASK THE COMMUNITY

TRENDING THREADS