Question Weird turbo issue Ryzen 2700


Aug 1, 2017
Mobo: ASROCK B450m HDV r4.0
CPU: Ryzen 2700 (non-x)

Voltage: 1.325

I've disabled turbo core boost in bios, I can run a stable 4.1GHz UNTIL it boosts for no reason (Screen will then turn black after a second or so, resulting in me restarting the pc)

I can have it at 3.9GHz, I have HWMonitor open when playing games, after about 2-3 minutes it will jump to 4.5GHz as max on HWMonitor.

and as I've said, I've disabled Turbo Core Boost in the bios, I can only imagine what the 4.1GHz core clock goes to when it decides to boost.

So am I missing an option in the bios somewhere?


This is at 3.8GHz, 1.3v, turbo boost only goes to 4.1GHz on a stock chip, im baffled why it jumps to 4.2 with anything labeled "turbo" or "boost" in the bios turned off. maybe HWMonitor is inaccurate.
Last edited:
Hey there,

List your full PC specs.

Just to be clear, the 4.1, 3.9, 3.8 you've quoted above are all core OC's?

It's not unusual for Ryzen to have an all core OC and still boost a little. My 1600x is at 3.9, and still boosts to 4.0 and sometimes 4.1, task dependant. It's not supposed to do that when you set an all core OC. The boost function is supposed to be disabled. At least that's my understanding.

It's mostly to do with the boost algorithm, XFR, PBO etc. If your cooling, voltage and temps of CPU and mobo allow, then the CPU can boost higher than advertised. mostly it happens on lighter loads, where the CPU has spare room with low temps, to boost higher.

I've had discussions with others on Tom's, one with a 2700x who's boost goes to 4.5/4.6! I've seen the screenshots, and believe this colleague and trust the results.

Some may put this down to the monitoring software not being updated, or using this software over that one. But nonetheless, the results are repeatable, and others have posted with the same thing.

So to rule out these things, make sure you have the most recent system drivers, bios (do a CMOS clear after bios update), and the monitoring software is up to date too. Most will recommend HWMon/Info.
Reactions: RodroX


Aug 4, 2019
What keith12 wrote.

Always use an up to date monitor software (and only one runing every time, if you use many you can mess the sensor readings). For me hwinfo portable ( is one of the best.

What BIOS version are you runing on the Asrock mobo?, also Did you updated the AMD chipset drivers to the lastest version from AMD website (

Keep in mind that an old BIOS and/or Drivers can mess things up.


Aug 1, 2017
HWMonitor is up to date.

Running the latest recommended bios for the motherboard (3.10)

AMD Chipset Driver is also up to date.

I've tried all the power option settings in windows aswell, setting their min processor state to 0%-10%, doesnt seem to change anything.

CPU at 3.8GHz hits about 50-60c max under load while playing a game for an hour.

Is there any way I could disable XFR/PBO? I dont see either of those in my bios, they are supposed to be under AMD CBS, but my bios only has half of what the mobos documentation says.

I feel like even if I was VERY unlucky, I should still be able to OC to max turbo speed and be stable right? because if I do that currently, the pc will blue screen as SOON as it tries to turbo to whatever speed beyond 4.1GHz. I'd say probably close to 5GHz.

Probably just a visual bug and I happen to have a very very unlucky chip, and mobo combo.


This is after 3? hours of playing FiveM, pretty populated server heavy on the CPU.

Mind you, max turbo speed on this chip is 4.1GHz, why is it jumping to 4.5GHz with a 3.8GHz manual OC? its definetely an ASRock issue, either that or visual. Its a buget board anyways not so they probably didnt intend for consumers to OC.

This is at 3.8GHz OC through bios, have had it at 3.8 since last night and it jumped to 4.2GHz when playing MW for about 30 minutes, seems the longer I play the higher the MAX clock speed on HWMonitor gets so ima assume its visual, dunno where HWMonitor is reading this info from tho thats what makes me wonder how its even updating to 4500.

If XFR/PBO is built into the CPU and asrock doesnt have a feature to disable it, ima assume thats what it is. I'll get another mobo in a few weeks that might have the settings for it.

Thanks for the help fellas.
Last edited: