Western digital caviar black wd5002aalx not recognized


Mar 1, 2012
I just recently replaced my mainboard with a duplicate of the one I had before (MSI 890FXA-GD70), because it crapped on me. Before my first board went weird on me, I had the WD Cav Black WD5002AALX HDD as my main drive, and it was working fine. After I got my replacement board a couple weeks ago, I hooked everything back up, and fired it up. Went through the usual BIOS setup, everything looked fine, said it recognized my DVD drive and HDD through SATA connections. System rebooted after saving the settings, but then it was reading "no bootable device". After trying different SATA power and data cables, to see if wiring was bad, it still was not picking it up. It would only load a "2.2TB Infinity" screen, then show my dvd rom drive. I tried putting in my windows 7 disk, and booting from there, still wasn't recognizing the HDD. Tried unhooking all my other SATA components and just having the 500gb HDD plugged in...once again read "no bootable device" upon rebooting.

So, all that, leads to my question, is there any other way to see if this HDD is still any good? Or is it safe to say I'm out $180....and I've only had it for about 4-5 months.

I'm currently running off a 128GB M4 SSD right now, but if this WD HDD is saveable, I wanna fix it and use it for file storage and what not.

Any help would be appreciated!