Western Digital Problem

Dina2616

Commendable
Apr 17, 2016
2
0
1,510
0
I have external hard WD 1T . it was fell down from short distant. the laptop can read it but when i start to copy/cut any file from hard to laptop or open any file on it ... the file appear word (not responding) in the address of the file
Note i'm using windows 10 & the hard normally appearing in the disk management but too slow
 

abhilaas

Commendable
Apr 16, 2016
84
0
1,660
21
All mechanical HDD may suffer significant damage if dropped even from a very short hight, and in many cases they even die after being dropped. There is nothing you can do in this case, do consult WD service centre for repairs, may be the disk platter or the read/write head needs to be replaced.
 
Welcome to the community, Dina2616!

Unfortunately, I'm afraid that @abhilaas is right. Mechanical hard drives are pretty sensitive and even the shortest insignificant drop, at first look, could cause quite the physical damage and corruption on the HDD. I'd advise you still attempt to connect the external using a different USB cable and to a different USB port on your computer. Another thing you should check is its health and SMART status by running the QUICK and EXTENDED tests from WD's Data LifeGuard Diagnostics Utility .
If you have important data on the drive that wasn't backed up elsewhere, I'd advise you consult with one of our Data Recovery Partners. Getting in touch with a professional company for assistance is your best bet on getting your files back. :(

Keep us posted with the results. Good luck!
SuperSoph_WD
 

tomsmith23

Reputable
Dec 14, 2015
53
0
4,660
10
Hi Dina2616,

First thing, I would like to suggest you that just copy your content instead of moving it as it may result into data loss. Further, I have few questions for you.

i) How do you copy your data?
ii) Have you tried all three methods to transfer your data i.e. drag and drop, copy and paste, copy command from the command prompt?
iii) Have you checked your hard drive with the help of error checking tool?
iv) Does this issue happen when you try it on another system?
 

Similar threads


TRENDING THREADS