Question What could be wrong with my PC?

Jan 24, 2020
5
0
10
0
Have just finished a fresh build and have been running a few days, however occassionally i get a loss of mouse/keyboard control and a freeze of image. this also sometimes is paired with a loss of video signal to my monitor. usually it fixed itself if i restarted the computer, however tonight, this issue occured and it forced my computer to reboot. i would assume this to be a graphics or power supply problem, however my drivers are all up tp date and im running a power supply that should be more than sufficient.

Components
intel i7 9700kf with noctua 12s cooler
msi radeon 5700 xt 8gb graphic card
predator hyperx rgb 16gb ram
asus rog strix z390-h motherboard
intel 660 1tb nvme m.2 ssd
2x wd blue 2TB 5400rpm harddrives
coolermaster 750w gold psu
 

rickypicky5

Proper
Sep 9, 2019
219
22
115
8
Did the fresh build include a fresh Windows 10 installation?

Do you have the latest non-beta BIOS for your motherboard? If I were you, I'd install:

Version 2606
2019/11/01


Is the PSU new? What is the exact model number of it?
 
Jan 24, 2020
5
0
10
0
Did the fresh build include a fresh Windows 10 installation?

Do you have the latest non-beta BIOS for your motherboard? If I were you, I'd install:

Version 2606
2019/11/01


Is the PSU new? What is the exact model number of it?
Just installed bios update and the windows instal was also fresh.
i have hwinfo, but cant quite see where to observe psu power bus voltages
 

rickypicky5

Proper
Sep 9, 2019
219
22
115
8
Just installed bios update and the windows instal was also fresh.
i have hwinfo, but cant quite see where to observe psu power bus voltages
Bring up hwinfo and select "sensors only". I think that will show the PSU info for +3.3, +12, and +.5. You may need to scroll up/down.

Let us know if the BIOS update helps. Good luck!
 
Jan 24, 2020
5
0
10
0
Bring up hwinfo and select "sensors only". I think that will show the PSU info for +3.3, +12, and +.5. You may need to scroll up/down.

Let us know if the BIOS update helps. Good luck!
Bios update didn't work unfortunately. And as of this morning, I can't get the screen to show anything past the initial boot screen, but it worked okay with the new bios last night
 
Jan 24, 2020
5
0
10
0
It seems as if this issue has gotten progressively worse too. As in the beginning, it would momentarily freeze or I could fix it by plugging the monitor back in, however now I cannot even get past the boot screens
 

ASK THE COMMUNITY

TRENDING THREADS