Question What have I done?

Jan 25, 2022
2
0
10
0
Right long story short I wanted to power a second graphics card in my personal pc, I found a 6pin to 6pin pcie cable laying around which I then connected by mistake on the psu to the peripherals then to my card... It never turned on since...
I understand that I have most likely shorted something on the board and I also understand that this was a rookie error.

Now I have obviously removed every single component to see if the mobo powers up but nothing... All the usual LEDs are on but no power, I have also removed the CPU power and also try to short the pins rather than using the power button.
Is there anything else I could try?
Is any of you guys know anyone who is repairing motherboards?
Nothing expensive but I had it for years and if possible I'd like to keep it, so any help appreciated 👍


Asus P8Z77-V LX
 

Wolfshadw

Titan
Moderator
I suspect your power supply is dead and quite possibly your motherboard and secondary graphics card. Might be a "rookie" mistake, but could very well be a very expensive one. I'd start with a brand new, quality power supply.

-Wolf sends
 
Jan 25, 2022
2
0
10
0
I suspect your power supply is dead and quite possibly your motherboard and secondary graphics card. Might be a "rookie" mistake, but could very well be a very expensive one. I'd start with a brand new, quality power supply.

-Wolf sends
Purchased crossair 650 yesterday, my first thought was that I killed a circuit inside the power supply, I have installed the new psu, still dead.

Thanks for the suggestion🙏
 

ASK THE COMMUNITY