Question What is causing my new PC to artifact?

Feb 7, 2020
6
0
10
0
During gaming I noticed my newly built PC producing artifacts, screen flickering and an orange grid flashing on the full screen for a frame or two along with system instability like CTD and system reboots.

I RMA'd the graphics card thinking that it's the likely cause and that this would solve my issue, but the issue persists even with the new GPU so it could be the RAM or PSU?

My system specs are:
CPU: Ryzen 5 3600
GPU: Gigabyte RX5700xt OC
RAM: 16GB Ripjaws V 3000mhz
MB: MSI Mortar Titanium Matx
PSU: BeQuiet 650 watt 80+ Gold

So i'm asking what other possible causes are there for these issues and how would I go narrowing down to the root cause?
 
Feb 7, 2020
6
0
10
0
gpu and monitor are sinc at the same frequency and refresh rate also bios is latest for the 3600 cpo alsp did check psu specs seams to have only 6 pins connector on for gpu and it need 2 x 8 pins ones .
My monitor has freesync which i am using.
The GPU uses an 8 pin and a 6 pin power connector and the PSU provides two 6+2 pin connectors.
 
Feb 7, 2020
6
0
10
0
bios should be 7b89va7 for the cpu and since psu havw 3 gpu power slot did yo try the other in to see if artefact stay on also witch temp you have when gaming .
I haven't tried the other outputs on PSU, I will try that.
I haven seen temps on afterburner reach 70 on GPU and 75-80 on memory, case is well cooled with x2 ML120 fans in front.
I am playing at 3440x1440 100hz.
 

ASK THE COMMUNITY

TRENDING THREADS