Question What is failing, Power supply, motherboard, mouse or something else.

Aug 27, 2019
2
0
10
0
Specs:

Motherboard: GA-Z87X-D3H
Processor: i-5 4670k @4.2ghz
Ram: 8gb ddr3 2400mhz
PS: antec true power 750w
Video: evga 1070SC
Sound: SB X-fi xtreme Gamer
Mouse Mx-518 (original)
Keyboard CM Storm Quickfire

So here is my issue. My usb ports appear to be randomly dropping. The most obvious place is in my mx518 which I will run at 1600dpi, but will suddenly disconnect then restart all the way to 400dpi. On rare occasion the keyboard will act like I am not pressing anything or am holding a key. But all this happens for a ms and then it is fine. I bump my mouse up to 1600 and can go for a while with no issues. I went through the whole process of dealing with windows power management, reinstalling the usb hub etc. I finally moved my mouse to my ps2 port. Now the mouse doesn't completely disconnect, but randomly drops to 400dpi setting even on the desktop. I cannot find a reason. Today when I went to use my pc the ps2 mouse was not functional at all. I had to reboot. Then when I rebooted it took me to the cmos screen.. so I rebooted again. This time it came up fine with ps2 mouse still dead. I moved it to usb and it worked. So I rebooted again and PS2 port is working again or at least the mouse is working again on it.

I cannot for the life of me decide if my mobo is on it's way out.. my PS is going (5v rail seems fine in the bios at 5.1) or if something else is wrong. This computer has run fine for years.

I am at a loss.

Help
 

FALC0N

Splendid
Well, we can rule out the USB port since the problem carried over to the PS2 port. Does the mouse work correctly in the bios screen? Maybe its a software issue. Getting another mouse to test if its a mouse issue shouldn't be too difficult. I noticed you were overclocking. Maybe set everything back to stock and see if that has any effect.
 
Aug 27, 2019
2
0
10
0
The mouse seems to work correctly in the bios screen, though I am not in it for a long time. I did try removing the overclock and that made no change.
 

ASK THE COMMUNITY

TRENDING THREADS