Question What is happening to my Monitor?

Feb 18, 2022
15
1
15
0
So recently, I noticed when I turn on my pc my main monitor starts lagging. Even opening start menu, loading programs, everything lags. But my second monitor doesn't do any of that and is perfectly fine and running in a stable state.
I thought that maybe it is a windows issue, so I waited for an update to come out. Thats when I started getting white streaks go across my screen when turning my pc on and getting to the desktop, everything was still lagging, but my second monitor was still completely fine. The weird thing is that when I log out of Windows, and back in, the issue fixes itself, I thought maybe a startup program caused this but nope.
I thought it maybe a GPU issue but I ruled that out, I switched the cables and the issue still persisted. When I turned my pc on once, I went to the toilet and came back to my monitor in this state:
View: https://imgur.com/cdoWwO9


Is my monitor dying? Everything is up to date, even display drivers. The GPU is almost a year old but I don't think it's that since my secondary display seems perfect
 
Feb 18, 2022
15
1
15
0
its not good, thats for sure. Do you get that picture if you plug it into another PC?

does it look like that in safe mode?

what make/model monitor is it?
Unfortunatley I do not have a spare PC to test this on, I havent tried safe mode either as it only happens around once a day.

The Monitor model is
ASUS ROG SWIFT PG278QR

https://www.amazon.co.uk/gp/product/B01LWQGIUR/ref=ppx_yo_dt_b_search_asin_title?ie=UTF8&psc=1
Here is the link from Amazon where I grabbed it


EDIT

This is the issue that appears everyday. I thought it could be wallpaper engine but it started before I used it
View: https://imgur.com/a/OSq2Y6h
 
Last edited:

Colif

Win 11 Master
Moderator
Jun 12, 2015
61,167
5,188
166,290
10,454
does it look at all like a smaller version of your desktop image but somehow showing as little squares all across desktop? was just thinking the black bar at bottom of every square could be the taskbar.

It doesn't help, just tossing it out there.

what refresh rate are you running screen at?
most of the problems I find for that monitor are for blurry screens.

how new is screen? I would ask on here and see what they suggest - https://rog.asus.com/forum/forumdisplay.php?175-ROG-Series-Monitors-(PG-XG)
 
Feb 18, 2022
15
1
15
0
does it look at all like a smaller version of your desktop image but somehow showing as little squares all across desktop? was just thinking the black bar at bottom of every square could be the taskbar.

It doesn't help, just tossing it out there.

what refresh rate are you running screen at?
most of the problems I find for that monitor are for blurry screens.

how new is screen? I would ask on here and see what they suggest - https://rog.asus.com/forum/forumdisplay.php?175-ROG-Series-Monitors-(PG-XG)
You are exactly right, they are just little squares with my desktop image in them. I'm running at 144hz and the monitor is around 3 years old
 
Feb 18, 2022
15
1
15
0
when you say you swapped cables, have you tried swapping the connector type? used HDMI or Display Port?

I think the monitor is the problem - https://rog.asus.com/forum/showthread.php?78341-PG278Q-Horizontal-Lines
I havent had chance to try a different display cable, I am currently trying to find where my old HDMI is but I will see if it happens again
I looked at the forum page you linked and it does seem like a very similar issue. I think it will be my monitor dying
 

ASK THE COMMUNITY

TRENDING THREADS