Question What is happening with Windows 10?


May 18, 2020
I have an acer gaming laptop (A717-72g-700j) that is older than 3 years, but it was running good until yesterday. I usually leave my laptop running because it works as a mobile hotspot to enable Wifi connection for my other devices. Yesterday, my laptop was running normally and suddenly a blue screen appeared on my laptop saying there is an error that must be fixed and the laptop must be restarted. I thought it is okay, just a small problem that will be automatically solved.

After the restart, I signed in and nothing appeared, just a black screen with the mouse cursor. No apps or taskbar or anything else showed up, only the mouse cursor and those signs that appear when pressing caps lock or num lock for example. I tried pressing ctrl + alt + delete and opening task manager, but again only the task manager showed up and nothing else. I tried restarting the laptop several times and each time I restart it, a message appears in the startup screen with the acer logo and loading dots saying "scanning and repairing drive c".

I have never seen this message before and the process took only a few seconds each time I restarted it but then after the lock screen appears and after I sign in, the black screen showed again. One last time, I tried restarting it again but this time it worked. I thought the problem was over and went to sleep. Today I realized that the problem wasn't completely solved. Some apps and files were corrupted. For example, Origin launches everytime I start the laptop but now it just gives me a weird message about an error and some files missing and it refuses to launch.

I had a Zoom meeting today for my studies but Zoom didn't work either and I was forced to use my phone to attend the meeting. Also the start button on the bottom left doesn't work and the start menu doesn't show up when I click it. I searched for solutions and tried using system restore but the unfortunately I didn't create any restore point before and the only one that was automatically created was yesterday nearly at the time this problem happened. I tried restoring my laptop using this point anyway but nothing changed. I can also reset my laptop but I don't want to delete all the apps and files I have. It will take a lot of time to redownload everything and I won't be able to restore all my personal files as well. I also don't have a usb drive or an external hard disk in which I can backup all important files, therefore I will only resort to resetting my laptop after I run out of all other solutions, and that's why I'm posting this thread to ask if anyone has ever faced this strange problem and knows what in the world is happening and if there is any solution for it. I'm really lost and have no clue why that happened and I'd appreciate any help I can get.

Mod Edit for readability
Last edited by a moderator:


Sounds like your storage drive corrupted, giving you bad sectors in some critical areas. Replace the drive and reinstall Windows and apps. Recover your personal files from your backups (if you made any).

-Wolf sends