• Now's your chance win big! Join our community and get entered to win a RTX 2060 GPU, plus more! Join here.

    Meet Stan Dmitriev of SurrogateTV on the Pi Cast TODAY! The show is live August 11th at 2:30 pm ET (7:30 PM BST). Watch live right here!

    Professional PC modder Mike Petereyns joins Scharon on the Tom's Hardware Show live on Thursday, August 13th at 3:00 pm ET (8:00 PM BST). Click here!

Question What memory does everyone use for an Asus Tuf x470 plus gaming

Feb 3, 2020
8
0
10
0
Hey guys I recently discovered that I foolishly bought memory that is not supported by the Asus TUF X470-Plus gaming motherboard. Before anyone asks yes I have went and looked at the QVL from Asus so I know what is supported now.

I would like to know what anyone with this board uses as far as memory?
 
Feb 3, 2020
8
0
10
0
I have the Crucial Ballistix Sport 16gb kit (2x8gb) DDR4- 3000
Model number: BLS2K8G4D30BESBK

This kit will only work in single channel mode. If I try to boot in dual it will not post. I also sent the original mobo back to asus and they sent me a replacement but both boards will only post with this memory kit in single channel. Ive also tried to boot with each of the sticks in by itself and it works fine. Also when I go into the bios after putting memory in single channel it wont reach the 3000 speed. Even with me "overclocking" it.
 
I have the Crucial Ballistix Sport 16gb kit (2x8gb) DDR4- 3000
Model number: BLS2K8G4D30BESBK

This kit will only work in single channel mode. If I try to boot in dual it will not post. I also sent the original mobo back to asus and they sent me a replacement but both boards will only post with this memory kit in single channel. Ive also tried to boot with each of the sticks in by itself and it works fine. Also when I go into the bios after putting memory in single channel it wont reach the 3000 speed. Even with me "overclocking" it.
1) Make sure it's in the right slots:



2) CLEAR CMOS. You need to reset your BIOS to unbork your settings.

3) Power On Self Test.

4) Post here your results.

5) We will discuss speed tuning after we get you running at stock.

Edit: I'll be back in a couple hours to check on you.
 
Last edited:
Feb 3, 2020
8
0
10
0
Thats what the problem is. I have tried every configuration of which slots. It will post with 1 stick in A1 or with 1 stick in A2. It will post with 1 stick in B1 or 1 stick in B2. Doesnt matter which stick of ram I use either so those both work. It will post with slot A1 and A2 occupied. It will post with slot B1 and B2 occupied.

BUT, it does nothing with Slots A2,B2 occupied. It does nothing with A1,B1 occupied.

At this point I dont even care about the speed I just want to know why the heck I cant run dual channel. The memory sticks are both good. This is already the replacement board from Asus. I have no bent pins on the Cpu( Ryzen 3 2200g). That and I dont really want to fork out $70-$100 on a new set of ram for it to not work either.

Whats the possibility that even the replacement Board is faulty too? If the first one even was...
 
I am about to walk out the door and won't be back for a bit but it sounds like the RAM works fine but there is something wrong with either the board or the CPU. Most likely it's a broken trace on the board. Examine it carefully and look for even the tiniest of scratches across the motherboard PCB. Use a flashlight and a magnifying glass and take a picture if you find anything suspect. I know you checked PINs but that's also a common cause for the memory controller not to work in dual channel. Check those pins again after you check your board.

Don't despair. You are on the right track to solve this, but you might be RMAing that mobo or CPU.
 

ASK THE COMMUNITY

TRENDING THREADS