[SOLVED] What to do if download speed is great but websites load slowly?

pepepapaujratam

Commendable
Oct 19, 2017
17
0
1,510
0
For the last month or so my browsing speed started to get really bad. Sometimes it's completely fine but about 70% of the time websites take 7-10 seconds to load, and sometimes chrome even fails to load them for the first time. The problem is present on a computer with a wired connection, on a computer with wifi connection, and even on my phone. From time to time one messenger message takes 10 secs to deliver. If I open a Youtube video the loading circle spins for again about 10 seconds but after that when the video starts it buffers quickly. My download/upload speeds are not bad, it's just that every time I want to access something it takes a long time. Restarting the router seems to temporarily fix the problem for half an hour or so. Is there a setting in the router configuration that can fix this problem? I've been using this router for 4 years and until now, everything was fine with the same devices connected to it. Maybe I have to reset something?
Thanks in advance,

Peter
 

pepepapaujratam

Commendable
Oct 19, 2017
17
0
1,510
0
malware scan your system?
Although I couldn't find any viruses on my computer, after reinstalling Windows the browsing speed got normal again on all devices in the house. Whether it was a virus or just some faulty settings the problem was on my PC. Resetting the router, resetting network settings in Windows, or changing and flushing the DNS didn't make a difference.
 

ASK THE COMMUNITY

TRENDING THREADS