Question What to do with a no screen/post caused by a power surge during a bios update?

Apr 12, 2019
2
0
10
0
So this is going to be a long post since this is my first time building a pc and writing in this forum even though I do use this source a lot for useful information but I was wondering if my computer is still usable after this incident that occurred?

PC Parts List:
CPU: AMD Ryzen 5 1600(new)
MB: Gigabyte B450M DS3H(new)
RAM: Crucial Ballistix AT 16GB 3000Mhz(new)
Storage: Kingston SSD 240GB(new)
GPU: AMD MSI R9 380(used)
Case: Thermaltake H17(new)
PSU: Corsair RM850 80+ Gold 850W(used)

So first time build the PC was hard and nerve wrecking but not too bad since I have been watching PC build guides for a long time now(2-3 years) and finally just got enough money to buy the parts. After I finished with building my computer, I hooked it up to my monitor and turn it on to see the bios. Got familiarized with it and then went to go download Windows 10 Installer on an usb. I have a MacBook Pro so I had to use Boot Camp Assistant to put Windows 10 on my USB using the ISO file that I download from Microsoft. After doing so I inserted the USB and loaded to a black screen. I thought this was weird so I looked up videos on ways to install windows from Mac to a new PC but got no luck. After a while, I just messed around with the bios to see if anything would work like setting the boot priority to my USB but that would just give me a black screen still and loading to my SSD just gave me a text saying to insert a boot drive/disc and press a key which I did but didn’t work. Keep in mind that I tried many things just to install windows like putting the USB into a USB 2.0 and 3.0 ports, disabling CSM even though I don’t know what that does, enabling fast boot with USB to use full initialization, and many more unsuccessful methods. Then updating the bios came into my head and when I did, the power went out,which it rarely does, for like a couple of seconds and then turned back on. My bios update was probably around like 90% done when this happened and at that moment I knew, I was done for. When I turned on my computer, nothing came up, but my computer still worked like normal. My case power button light turned on, my fans were spinning, my graphics card light turned on, but no post on my screen. I was completely devastated at this point. I checked around to see that my keyboard and mouse aren’t lighting up anymore like they did before so I knew something was up. Also when I try to turn off my computer by holding the power button, it doesn’t turn off but just flickers with my motherboard flickering and my fans spinning slowly. But when I let go, it still stays on and acts like normal. So I just press the off switch on my power supply. After going through so much for this to happen, I persevered and called up Gigabyte with the outcome of them telling me to reset my CMOS by removing the battery for like 10-15 minutes. I did what they told me to do and while waiting I looked up how to reset my bios by CMOS. My motherboard however did not come with the little CMOS jumper thing so I just took a screwdriver and touched CMOS pin for a while. Then I tried again after doing the CMOS resets and still doesn’t work. Now truly I am defeated so I just went to install windows 10 on my Mac and created a windows installer on my usb using the media creation tool. So at this point, I don’t know what to do...

TL;DR: first time building a pc, turned on the pc for the first time, it turned to the bios, downloaded windows 10 installer on an usb from MacBook Pro(even though I should’ve just went through the hassle of downloading from a windows computer), plugged in the usb and revived a black screen from it, did a bios update and got a power surge during the update, turned on the pc to get a no screen/post anymore, tried resetting bios by removing and putting back the CMOS battery, and yeah


My questions after all of that are:
  1. Is my computer good anymore after the power surge?
  2. Can a bios update surge an entire home(which I highly doubt)?
  3. What can I do to fix this issue?
  4. Is my motherboard bricked and what can I do to fix this?
 

Similar threads


ASK THE COMMUNITY

TRENDING THREADS

Latest posts