Question What's causing slow download speed ?

Jul 12, 2021
3
0
10
0
Ok so I looked and looked, either I'm blind, stupid or both.

But ever since I updated Windows 10 today I been super slow download speeds, only on certain downloads though.

I have around 800MBps download speed

For example downloading GFE which is 123MB is taking about 30 to 45 minutes to download but other downloads in similar size go by super quick.

I thought it could have been Nvidia servers but downloading 2 different programs from the same website, 1 downloads quick the other said it would finish in an hour (70MB File)

I've also experience packet loss while gaming since the update.

I'm not sure what else to do.
 
Jul 12, 2021
3
0
10
0
Might be just a coincidence that your isp is having issues right after your update. Run packetlosstest.com on multiple machines and if they all have packet loss, call your isp.
I did that packetloss test, it says 0 packets lost, but I'm still having the issue, I contacted my ISP and they said there is no issue on their end, and I get 0 packet loss and download issues on my phone when connected to wifi, and same for my laptop. I'm not sure if a driver update messed something up in regards to network drivers on what.
 
I would never let windows update any drivers. There should be a option to prevent this.

You have 2.5g ethernet port that already has all kinds of strange driver problems. You need to find one that is stable and then leave it alone. Could be windows loaded a older one......but it could also be a newer one that has issues.

It could also be that crap QoS software asus bundles with their motherboard. There is no way to affect network traffic outside your machine so it is pretty worthless and has a history of causing all kinds of issues. Best if you can uninstall it.
 
I did that packetloss test, it says 0 packets lost, but I'm still having the issue, I contacted my ISP and they said there is no issue on their end, and I get 0 packet loss and download issues on my phone when connected to wifi, and same for my laptop. I'm not sure if a driver update messed something up in regards to network drivers on what.
So if packetlosstest is saying you're not having packet loss, then you don't have any. What are you using that's telling you have loss?
 

ASK THE COMMUNITY

TRENDING THREADS