Discussion What's the deal with CSM?

Aug 2, 2020
1
0
10
0
I have ASRock Deskmini A300 that runs fine until one day it stops booting.
There is video signal to the screen but it just a black screen and no response from keyboard
By turning on the PC without nvme drive, it finally enters UEFI menu.
I thought my nvme drive is going to bust so i bought another one, but it still gives me the black screen.
At this point i kind of giving up so i tried turning on CSM in the UEFI at a whim, and it finally boots to Windows just like the usual days.

What do you think was happened to my PC? Why it needs CSM all of the sudden? It was fine without it...
Prior to turning on CSM i tried reseating everything and it successfully boot but by random chance, and restarting from there gives me black screen again.
 
Last edited by a moderator:

Colif

Win 10 Master
Moderator
CSM = Compatibility Support Module is there to emulate Legacy bios in UEFI systems. Your manual really doesn't tell you anything about it - https://download.asrock.com/Manual/A300M-STX.pdf

It sounds like the day it stopped booting, the boot method swapped from CSM to UEFI, and you turning it on, swapped the boot method back to CSM and it looked for the right files to boot. Clearly your WIndows is set up as legacy boot.

Does the PC have any Asrock utilities on it that can update drivers/Bios as its possible you got a bios update and it reset the defaults
 

ASK THE COMMUNITY