Question What's the deal with this 2080ti artifacting?

Jan 7, 2021
2
0
10
0
GIGABYTE NVIDIA 2080TI
64GB Corsair Vengeance LPX DDR4 3000MHz
850W - Corsair TX850M 80+ Gold Semi-Modular PSU
AMD Ryzen 9 3900X
ASUS ROG STRIX X570-F


So, couple of days ago, while playing Conan Exiles with some friends I started getting strange artefacts.
View: https://youtu.be/Zf0FETCDLho?t=6


Restarted the game - system, nothing.
Then I started noticing strange artefacts on my browsers and apps, the kind of which can be seen in the video below, both on images and videos.


It would often crash videos, browsers, and the occasional app, but here's the rub - besides Conan, all my other games run fine. No crashes, no artefacts.
View: https://youtu.be/fIQaN216T10


I've run FurMark to attempt to stress the GPU further and it seems fine! I've similarly run multiple memory tests to rule out RAM as the problem, such as memtest86

I'm getting no system crashes, freezes, BSODs, etc. No problems booting or powering...

So I've spoken to the company from who I bought the GPU and they're happy to RMA, but just for those of you out there who know infinitely more about GPUs than I do.

Definitely a GPU issue? Seems so unusual that I've got such a specific problem.

PS.
FYI I've tried to DDU the drivers, removing all my drivers made artefacting substantially worse.
An older driver seemed to fix the issue momentarily, before returning. Turning off hardware acceleration in my browser also makes it worse. Probably because I have no integral graphics support on my CPU.
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS