When plugged into Intel Graphics monitor works, but when plugged into GPU "no signal"


Jul 27, 2016
- Computer built in Oct 2014
- i7-4790k
- Asus Z97M-Plus Motherboard
- Gigabyte R9 290x Windforce
- 32GB G.SKILL Ripjaws X Series (4 x 8GB)
- CORSAIR RM Series RM850 850W

Last Friday I was gaming on my rig when suddenly my dual screens went black and I got a "no signal" message. Now as mentioned in my specs I've been using this PC for over two years with the same parts. Confused, I went online on my phone to search for possible issues. After unplugging my GPU and connecting one of the monitors to the motherboard (Intel graphics), it worked. That lead me to assume that my graphics card was dead. So I ordered a new one (Gigabyte GTX 1060 Windforce). It arrives, I plug it in... and "no signal." I try plugging the card into the other PCIe slot thinking the first might have been damaged. "No signal." I try resetting the CMOS. "No signal."

My computer recognizes all of my RAM, so I doubt that's the issue. The only question mark though is that for a few months whenever I power my computer it would turn on, then turn off a second later, then turn on again normally. The DRAM light goes red, blinks, and then the system boots normally.

What confuses me is that the issue happened WHILE I was using my graphics card. It's not like I changed some settings, turned off my PC, and then it won't boot again. And as mentioned, I can still use Intel graphics so everything seems to be functional.


Mar 4, 2015
same thing happened to me dude.Was playing Watchdogs 2 on my gtx 970 and suddenly BAM ..blacks out "CHECK FOR SIGNAL".it happened to me couple of times before while gaming(like overwatch) but it used to work again once restarted .But \Now its not working.Tried couple of solutions online but no use..i dont want my gtx 970 to be dead its only 2 years old.Presently using onboard card HD4600.My gpu is not being recognised by dev manager or any other shit.But the fans dont stop spinning.Let me know if you find a solution.i was overclocking it a little bit (LITTLE) i hope it wasnt the cause