[SOLVED] When second display is plugged in, computer doesn't start up

Sep 9, 2020
5
0
10
0
(Monitor that works) HDMI - Acer KA270H
DP - AOC 27G2G4
Computer - ATC-780-AMZi5 with a 750 ti and 430w PSU.
When starting up my computer with the AOC monitor plugged in, all my peripherals other than my keyboard light up, but no display output shows up, and there is no boot beep. With the Acer display by itself, it starts just fine, and I can plug in the AOC display afterward and it works fine as well. I've power cycled my computer, reset the CMOS, updated the bios, reseated the graphics card, and none of it has worked in letting the computer startup with both monitors. I dual boot Artix Linux and Windows 10, but I don't think that should affect anything.
 

Math Geek

Champion
Ambassador
well that's certainly interesting. never seen such a thing like that. perhaps a firmware update for the gpu is available? other than that, i am not sure. i don't think anything in the BIOS would help. never seen a setting dealing with extra displays.
 

Math Geek

Champion
Ambassador
does the system boot with just the new AOC monitor plugged in? same port as other one and/or a different port still by itself? does it boot with the Acer plugged into a different port by itself?

need to check a few variations to see if you can narrow down what is happening.
 
Sep 9, 2020
5
0
10
0
With HDMI by itself, the AOC monitor does work, but with DP by itself, it doesn't. The Acer monitor only has HDMI and VGA, and I don't have a VGA port unless I go with integrated graphics. It's starting to look like a problem with my DP port on my graphics card.
 
Sep 9, 2020
5
0
10
0
Yes, it works with HDMI. Looks like I have to get a DVI to HDMI adapter for my Acer monitor. Or I just replug my monitors every time I restart.
 

Math Geek

Champion
Ambassador
it is odd that it works after you boot up. suggests the port is working fine.

but for some reason it does not want to boot up that way. have you tried disabling the second monitor while in windows and then rebooting. this will only show the main acer and not the aoc one. but it will be plugged in. different way of trying to boot with both monitors plugged in.

i have 3 monitors and sometimes have any combo of them enabled on start-up. never seen such an issue if they work once booted up.
 
Sep 9, 2020
5
0
10
0
well that's certainly interesting. never seen such a thing like that. perhaps a firmware update for the gpu is available? other than that, i am not sure. i don't think anything in the BIOS would help. never seen a setting dealing with extra displays.
Thanks! I needed to update the firmware to for display port to 1.3/1.4. It worked just fine after that.
 

ASK THE COMMUNITY