when typing on a windows system freezes

Mar 2, 2018
every time I open a window and start typing, after a minute or so, the pc, the window border changes color and th mouse cursor disappears . If I try to type when this happens, the pc starts making sounds ...To get back have to bring the mouse cursor to the last position and do click, after this the sstem comes back to normal..The PC makes this event every 30 to 45 seconds........!
It happens to when open any window and wait....after a period of time the border color changes and freezes...Have to wake it up with a mouse click........???????

Please HELP .....!



Feb 16, 2018

Unfortunately, the default power settings dumb-down the possible speed of the computer.

Start> Control panel > look in the upper path bar, click on the arrow ">" after "control panel."
this opens a drop down menu
Then click "All control panel items"
Click: Power Options
Click: Show Additional Plans
Click: The arrow, check the box that says "high performance."
Click: Change Plan Settings
Turn Off Display: Never
Put Computer to Sleep: Never
Click: change advanced power settings
Hard Disk : turn off hard disk after: Never
Wireless adapter Settings: power saving mode Setting: Max Performance
Sleep: sleep after: Never
Allow Hybrid Sleep: Setting: Off
Hibernate After: Setting: Never
Allow Wake Timers: Setting Disabled
USB Settings: selective suspend setting Setting: Disabled
PCI Express Link Power State Setting: off
Display: turn off display Setting: Never (turn off monitor manually if desired)
Multimedia Settings
When sharing media : prevent idling to sleep
When Playing video: Setting: optimize video quality
Now: Click "OK"
Computer> system properties > Now open the Device Manager
Click On: mice and pointing devices ">" click on the arrow
Double Click on HID complaint Mouse
Click: power management tab
UN-check the box that says: "allow computer to turn off this device to save power"
Now open all devices on the list, and turn OFF all power savers, for every device, as above.
Now Click " OK"
Antivirus: set for "multimedia mode."
This prevents updating from interrupting your media. If you do not have an antivirus with this feature: get a different antivirus.
Set ALL updates to: manual. This prevents an update from eating resources that you would otherwise be using.

Free antivirus from internet: I do not recommend that you install any "free" security tools.
I do not recommend installing "cleaner," "sweeper," "driver helper,"or any free junk from the internet.

Avoid any download which claims to "fix" your computer.

I recommend that you use a professional all-in-one security application - not a free download.

Please consider, when you install multiple security programs, they can conflict with each-other. That's why you should use "all-in-one" pofessional security.
Restart the computer
Open Bios
Turn off Cool and Quiet (if AMD processor) Save and exit bios settings.
Restart Computer
Problems should be fixed now.