Question When using Dual Channel Ram, It will not boot up. (Explained everything I have tried and done)

Dec 27, 2019
5
1
15
0
As the title says, I am unable to boot when trying to use dual channel.

I am 100% sure my ram is not faulty and is compatible. Here are the specifications:
For the RAM I am using: https://www.amazon.ca/Corsair-Vengeance-3200MHz-Desktop-Memory/dp/B01EI5ZRQY/ref=sr_1_3?crid=2NOXFFEX6CAJD&keywords=corsair+vengeance+lpx+16+gb&qid=1577503217&sprefix=corsair+vengea,aps,195&sr=8-3

Model is:
CMK16GX4M2B3200C16W

If we search in the supported RAM list then
CMK16GX4M2B3200C16 comes up. The only difference is the color, the W is white.

For the motherboard, I am using Asus ROG Strix Z390-F.

The processor I have is Intel i9 9900k.

Here is what is happening: So there are 4 slots. I try to use it at A1 B1, won't work. A1 B1, won't work. I tried A1 A2 as well, that won't work either. Only B1 B2 works. I tried doing other combinations as well. So when I try to put it in dual channel, it tried to reboot as said in the manual the motherboard is trying to load the profile for the ram. But that does not seem to be the case. It looks like it is trying to find it but for some reasons after quite a few tries it gets stuck on the RAM issue as the static yellow light turns on which says ram. (Pardon me if I am wrong).

Now there are so many things I have tried and searched for:
  • Contacted Asus ROG support, they said I can file RMA.
  • Updated BIOS
  • Reset my motherboard to factory settings.
  • Tried every single RAM combination there is.
  • I tried loading into BIOS with a single ram stick then using different settings for example XMP on or off. Still not fixed.
  • I tried different RAM Voltages.
I recently ordered this RAM stick, the ones I have before had the same issue, I thought ordering new ones which are same would fix it but that does not seems to be the case. I can return them but I have been gaming on single channel all this time. SO please, if someone can help me please do! I will be active as much as I can on this thread so if there is something you need to ask or say please do, I will reply you. Any type of help is grately appreciated. What would you suggest I should do? If anyone needs me to upload a VIDEO, I can do that too.
 
Dec 27, 2019
5
1
15
0
Hello,
I have the same problem, are you sure that this is the solving ?
I have the same componenta as mbo and dimm
I fixed my problem. Apparently there were 2 bent cpu pins and I had to use tweezers, magnifying glass and a lot of light to put the pins back in shape and now it works perfectly.
 

ASK THE COMMUNITY

TRENDING THREADS