Question White-ish filter on my screen ?

Jun 19, 2021
31
2
45
0
Don't even know how to describe this but my one screen always has a whiteish filter like if there were a thin layer of milk on my screen.
But sometimes when i turn my PC on, the 2nd screen won't turn on, and the whiteish filter is on my main screen. All i then do is disconnect the screen and plug it right back in, and the whiteish filter moves to my 2nd screen again.

It happens even on a freashly installed windows.
Have changed GPU in the meantime, and the issue is still persistent

GPU: Asus Strix 1080 AG 8GB
Screen 1: AOC G2770PF
Screen 2: AOC G2460F

I have also tryed to calibrate the screen but is reset upon restart and first uses the calibration when i go into Settings --> Display settings then my calibrated settings apply once again.


Do any of you have an idea on what i should do?
 

Ralston18

Titan
Moderator
What connectivity are you using between GPU and screens? HDMI, DVI, DP?

Which screen is the Primary screen?

Do you have other known working video cables that you can swap in to determine if the problem continues?

Are you using Duplicate or Extend for screen display via "WIN + P" key menu?

Verify that you are indeed saving, "Ok", approving, or otherwise making the desired calibration settings "permanent".

Night light settings?

https://support.microsoft.com/en-us/windows/set-your-display-for-night-time-in-windows-18fe903a-e0a1-8326-4c68-fd23d7aaf136
 
Jun 19, 2021
31
2
45
0
Using DP. Same result with HDMI and switched cables.

Screen 1 is main, exstended to screen 2.

No nightlight settings, and it is saved and can be choosed in profiles.

I could undstand if it was the screen alone, but the fact that my main screen gets the whitefilter and the other one doesn't turn on till either restart of replugging the DP cable, is conserning
 

ASK THE COMMUNITY

TRENDING THREADS