Question White led vga always on

Apr 4, 2021
26
1
35
0
  1. The white led vga was always on and had a display.
  2. I reseat the gpu on the same slot
  3. Now it has no display anymore
  4. I plugged it on different pcie slot
  5. It had display but still the led vga was still on
  6. I plugged it back to its original pcie slot in the 1st slot and the vga light was gone
  7. My pc is working now
  8. I noticed that the pcie bus etc. driver were not installed in the first place
  9. I updated the said driver
My question is, wth happened? Just to make sure if I did the right thing and what should I do to avoid the said problem in the future?

SPECS:

i5 10400f
Asus Rog Strix B460-F
G.skill Aegis 2400mhz 8x2
MSI aero itx 1030 2gb oc
Tammuz SSD 128gb
Seagate HDD 500gb
ID cooling SE 207 XT cpu cooler
1st Player FK - 500w true rated 80+ PSU
Rakk Hawani Flow Black ATX Tower Casing
 
  1. The white led vga was always on and had a display.
  2. I reseat the gpu on the same slot
  3. Now it has no display anymore
  4. I plugged it on different pcie slot
  5. It had display but still the led vga was still on
  6. I plugged it back to its original pcie slot in the 1st slot and the vga light was gone
  7. My pc is working now
  8. I noticed that the pcie bus etc. driver were not installed in the first place
  9. I updated the said driver
My question is, wth happened? Just to make sure if I did the right thing and what should I do to avoid the said problem in the future?

SPECS:

i5 10400f
Asus Rog Strix B460-F
G.skill Aegis 2400mhz 8x2
MSI aero itx 1030 2gb oc
Tammuz SSD 128gb
Seagate HDD 500gb
ID cooling SE 207 XT cpu cooler
1st Player FK - 500w true rated 80+ PSU
Rakk Hawani Flow Black ATX Tower Casing
Do you have your latest bios and mobo drivers if not then that would explain it
 

ASK THE COMMUNITY