Question White Light on motherboard, no display, after turning pc on and off for several times, everything works fine

May 17, 2022
1
0
10
0
Hey guys,

Ever since I switched to a Mini ITX build, my monitor isn't working well when I press the power button on my pc. Changes made were the motherboard and psu. Here are the specs:

Motherboard: Asus ROG STRIX B450-I
CPU: AMD Ryzen 5 2600
GPU: NVIDIA Geforce GTX 1060 6gb
RAM: TUF Gaming Alliance 16gb (8gbx2) DDR4-3000
SSD: Corsair MP400
PSU: Corsair 450W sfx

So when I first turn on my pc, the motherboard stays on the white light. I have to turn it on and off again for about 3 times before it gives a green light and the monitor displays something. All the peripherals light up on the first power up. There are no issues with the GPU when I play games, everything runs smooth apart from the getting the monitor to work. I am using a display port, I have tried to use an HDMI cable but the problem remains the same.
 
Hey guys,

Ever since I switched to a Mini ITX build, my monitor isn't working well when I press the power button on my pc. Changes made were the motherboard and psu. Here are the specs:

Motherboard: Asus ROG STRIX B450-I
CPU: AMD Ryzen 5 2600
GPU: NVIDIA Geforce GTX 1060 6gb
RAM: TUF Gaming Alliance 16gb (8gbx2) DDR4-3000
SSD: Corsair MP400
PSU: Corsair 450W sfx

So when I first turn on my pc, the motherboard stays on the white light. I have to turn it on and off again for about 3 times before it gives a green light and the monitor displays something. All the peripherals light up on the first power up. There are no issues with the GPU when I play games, everything runs smooth apart from the getting the monitor to work. I am using a display port, I have tried to use an HDMI cable but the problem remains the same.
Can you try your old psu just as a test?
 

ASK THE COMMUNITY