White screen when gaming with Ati Radeon HD 4870

heavywater

Honorable
Aug 9, 2013
16
0
10,520
1
hi,
since i have my Ati Radeon hd 4870, due to failure Geforce 9800gt, i have problems with getting white screens randomly when gaming/using graphically apps.

atm i'm running:
windows 8 pro 64bit
Asus M4a78 motherboard
Amd Phenom x3 8650 2.3ghz
xfx Ati Radeon HD 4870
4x 1gb Kingston DDR2 667
Toshiba THNSNS128GMCP 120 gb ssd
Hitachi HTS727550A9E364 500 gb hdd
an offbrand usb 3.0 controller
2x Silverstone FM121 (1 in 1 out) @100% 2400 rpm
1x 70 cfm 12cm cooler against my vga/chipset
Scythe "SHURIKEN Rev.B " 3Heat Pipes CPU Cooler
Sharkoon Rex3 value edit white
750w ADVANCE TX-750W psu

when i want to run serveral games, (Auto club revolution, Need for Speed World, Wow wotlk) high and low performance, after 5-30 mins my screen turns white and my pc restarts 9-10 times after the white screen, my windows loading circle turns around like it wants to reach light speed, and when in windows my clock skips the minutes every 1.5 seconds.
when i use programs like Aida 64, cpuid pc wizard or hardware monitor, it says my +12v rating is 15.312V, but when i look in my bios it says 11.6V i dont really know what is the problem now, i tried serveral psu's and all where close to 15V it's not cooling since i had this problem with stock coolers but also with the high performance cooling, (even with 1x silverstone fm121 and scythe gentle tyfoon @5400 rpm [in-out and in-in setup])

i dont have these problems with my Geforce 9800Gt so i guess it's my gpu thats causing these problems. i hope someone here can help me out ^^

*all drivers are up to date*


 

gdanl19

Honorable
Jun 18, 2013
9
0
10,520
1
I had a similiar problem with a newly installed HD 7870 Radion card. I immediatley downloaded the newest drivers for the card and the problem went away.
 

heavywater

Honorable
Aug 9, 2013
16
0
10,520
1


i did that 3 times.. also tried beta drivers but no use :(
 

meowmix44

Honorable
Jan 3, 2013
986
0
11,060
43
It could be missing things that your GPU doesnt support! Try running a old game, if it works then its not drivers, its because your GPU does not support it. The way I would check would be to download this demo and if you get another whitescreen, then the newer games wont work at any resolution. http://www.youtube.com/watch?v=v2DbnHmoh2k

Im not being a sponsor or other bull**** Im serious on this one.
 

meowmix44

Honorable
Jan 3, 2013
986
0
11,060
43
It could be missing things that your GPU doesnt support! Try running a old game, if it works then its not drivers, its because your GPU does not support it. The way I would check would be to download this demo and if you get another whitescreen, then the newer games wont work at any resolution. http://www.youtube.com/watch?v=v2DbnHmoh2k

Im not being a sponsor or other bull**** Im serious on this one.
 

heavywater

Honorable
Aug 9, 2013
16
0
10,520
1


well i tried both things, the "game" didnt show anything exept graphics options when launched, and these are my gpu-z results (i didnt know what to look for so i'll post this pictur ^^)


and the games i get white sreens with, are: Need for Speed World (2010 still updated shader support 2 or 3)
and World of Warcraft Wrath of the lich king (2010 direct x 9)
 

heavywater

Honorable
Aug 9, 2013
16
0
10,520
1
Atm i use 2 Powersupply's
750w ADVANCE TX-750W psu (main)
650w ADVANCE TX-650w psu (2nd 6pins gpu connector)

with this setting, i experienced a whitescreen too.
with meowmix44 his tip to use gpu-z i came at the idea to flash my vbios
after this i ran my heaviest games for an hour, and i didn't get a white screen.

now i'm off to work when i get back i'll remove the 650W psu and retry if i dont get a white screen i guess there was an error in my vbios ^^
 

Similar threads


TRENDING THREADS