Question Who really knows why our displays dim and brighten slightly when mouse hovers over different windows/icons/pictures???

QuadriplegicGamer

Prominent
Oct 6, 2020
7
0
510
0
System specs at bottom of post.

The PROBLEM- when the cursor hovers over certain things on screen like icons, buttons in creator applications, brighter or darker areas of the screen(can be just about anything), the screen will slightly, but noticeably brighten or darken, and sometimes flicker back and forth(like its confused about whether to dim or brighten) not a "glitch" like flicker that you might see with a failing GPU or faulty cable. Then, when you move the cursor just off of said thing, the screen darkens, move it back, the screen brightens again, or flickers. This most notably happens when there is large area of white on screen, like when working in Adobe Illustrator, Inkscape, Gimp, Excell, etc...

Others have complained of the same issue, with no real consensus on what is causing the behavior.

I'm looking for the definitive answer for why this happens. But, before you answer or input, please note, that this IS NOT:

  1. A driver issue (have installed fresh 472.xx Nvidia drivers... more than once)
  2. A bug or glitch from hardware/software failure(this is an apparent, intentional design feature)
  3. The Windows battery saver feature that is designed for laptops and tablets (I am using an HPDT, with win11, was happening in win10 as well)
  4. Environmentally influenced by ambient light sensors(my monitor has this turned off)
  5. Performance option related (all desktop performance options throughout windows are maxed globally and some per-application specific, like AI, Inkscape, and Gimp)
  6. A monitor "issue" (using a PG43UQ($1,500 model, and have multiple monitors hooked up, and all exhibit same behavior)
  7. A cable "issue" (using DP 1.4 and have used HDMI 2.0, and have changed many cables, and all inputs and outputs my hardware has to offer)
  8. A graphics card "issue" (I have a flawlessly running RTX 3090 I've had for just over a year now, I have swapped in a 2070, does the same thing)
  9. A monitor option (I've been through all the options my monitor offers, including ASUS' "ASCR", but that does not change the behavior either.)
I am trying to get to the bottom of this. I cant find the origin of this "feature" because any time you search for anything related to screen brightness or contrast, all you get is Microsoft tech affiliates telling you to turn off the "auto brightness" feature in Windows settings. THIS is NOT THAT.

system:
i9-10900k
Z490 vision Mobo
RTX 3090 Vision
32 gb vengeance RAM
PG43UQ monitor
2 other Samsung monitors
Activated Windows 11 Pro
 
Last edited:

Ralston18

Titan
Moderator
Cursor....

Make and model mouse?

Reinstall the applicable Windows 11 mouse drivers via a manual download, reinstall, and reconfiguration.

Failing that then try another known working mouse to determine if the same behavior occurs.
 

QuadriplegicGamer

Prominent
Oct 6, 2020
7
0
510
0
Thank you very much for the reply. I will try your suggestion. Are you saying this IS being caused by a mouse/HID driver? Have you seen this before?

Though, I have strong suspicion that this is not related to peripheral hardware or their drivers. I think this is some sort of power, eye, resource saving feature run by software code(suspecting Windows, Nvidia, maybe even ASUS monitor software, who knows) but I'm pretty sure its a "feature". Judging by its repeatable and specific behavior, it is apparent that this is intentional, not a malfunction of hardware(mouse) or software(driver).

I am using 3 different "pointer" HIDs, a Quadstick FPS(integrated Win driver), a Peripad-504 track pad(integrated Win driver), and an MX logitec mouse(logitec driver). All do the same thing when moving the mouse cursor.

For instance, say I am using Adobe Illustrator. When I move the mouse cursor over: a search field, set of buttons, the white canvas, or grab certain nodes or lines in the work area, I get brightness changes either dimmer or back to normal, one or the other, always the same.
 
Last edited:

QuadriplegicGamer

Prominent
Oct 6, 2020
7
0
510
0
After some more fiddling with my system, I think I've found what is causing my issue. It seems that its related to how Windows handles HDR. When I turn on sRGB mode(HDR off in Windows settings) the behavior disappears. So, when HDR is on, it seems that there is some sort of dynamic contrast/brightness feature that sets the contrast/brightness based on what Windows thinks you're looking at(by sensing the pixel shade at the tip of the mouse cursor/pointer). And, it doesn't seem to be an option that is able to be adjusted.

Does anyone know if this is a programmable feature? If so, how to change it?
 

meitou

Distinguished
May 2, 2011
144
0
18,680
0
Having the same issue with my computer after recently doing a clean install. When covering over certain content, the screen will darken, noticeably. As mentioned before, this is not a glitch because as soon as I move the cursor off the content, the screen will behave normally. For me, its not a HDR issue as I have it turned off in both my monitor and PC settings.

For example, if I hover over the black sections of Dolby ATMOS on the sixth image on this amazon link for a Panasonic SoundSlayer Gaming sound bar, my screen will darken: https://www.amazon.com/Panasonic-SoundSlayer-Subwoofer-Bluetooth-Passthrough/dp/B08FBJWM8K

I don't think it's a driver issue for me because I did a clean install of my computer again after I noticed this issue appearing after the first clean install. I'm currently using Windows 10, newest update version. I also performed a clean install of my drivers during the original nvidia driver update.
 
Last edited:

DCNOS18

Distinguished
Feb 22, 2014
100
1
18,715
12
Windows. is notoriously bad at handling HDR, I'm going to guess that's what the issue is here. Sounds like windows is trying to tone map sdr to HDR. Looks like it may be an effect of this windows feature https://docs.microsoft.com/en-us/windows/win32/direct2d/hdr-tone-map-effect. Also, this may fall under your #5 option but if you haven't already try changing the power settings in NVidia Control Panel under Manage 3D settings-> global settings ->power management mode -> maximum performance. Also, it would be nice to get a quick video to see exactly what you're talking about just for curiosities sake.
 
Reactions: QuadriplegicGamer

QuadriplegicGamer

Prominent
Oct 6, 2020
7
0
510
0
I will try to get this on video. I'm not sure if a software capture program would pick it up or if I'd need to record it live from a camera or phone. I suspect the later.

And, yes, I have changed those settings in Nvidia's control panel. Good suggestion though.

What's interesting is that I only find threads complaining about this issue on Nvidia's site and Creator software forums. Though, this does happen in Chrome and occasionally other software, I mostly encounter it in creation software I've mentioned above. Hmmm...
 

ASK THE COMMUNITY

Latest posts