[SOLVED] why did my fps go from 60+ to 2?

Feb 21, 2021
10
0
10
0
i was playing valheim and had to minimize my game. When i maximized it again my fps dropped from 60 to literally 1 to 3 fps. "Slideshow" is an understatement.
I restarted the game, same problem. i restarted my pc, same problem. I tried other games and Supreme commander runs fine somehow. halo pc, csgo and apex legends both running at 1 - 3 fps from the moment i launch the games.

I then updated my gpu drivers to the current 21.2.2 drivers for amd and it didn't fix the problem.

weird part: i ran furmark SEVERAL times (1080p no AA) and my gpu did fine with 90 fps average. max temp was 88c but thats supposedly normal for older AMD cards. I Ran cpu burner and it also did fine with zero lag in background aps with the stress test running at 100% cpu usage and normal temps....

I can't figure out what would cause Some video games to run like absolute garbage but still be fine during stress tests and in certain games. if it was a hardware issue surely it would happen all the time right??

Please Help! im not a novice when it comes to troubleshooting, but this has me stumped.

i have an r9 290x and an fx 8350.
 
Feb 21, 2021
10
0
10
0
Ok no obvious issues there. When the FPS drops does the cpu or gpu speed (GHz) drop at the same time while staying at 100% usage?
according to msi afterburner the gpu core clock jumps from 301 to 850 during the fps drops. Voltage goes up slightly as well. it doesn't tell me the cpu clock though,
 
Feb 21, 2021
10
0
10
0
Ok that rules out another idea I had
yeah this is really strange. i tried doom eternal on vulkan to see if it had something to do with openGL and i got 400 fps in the UI (which is 3d) but the moment i launch the campaign it goes back down to 1 fps. I still can't explain why both the gpu and cpu are seemingly fine in stress tests and benchmark software but are incapable of running Much less demanding games.
 
Feb 21, 2021
10
0
10
0
update: I made a little bit of progress. i ran unigine heaven benchmark and MS directX 11 gave me the same fps problem but openGL was fine. ill try reinstalling ms directx and post another update after.
apparently you can't just Update MS directX... so I guess im stuck playing games made for openGL API lol... weird. you'd think if it was a hardware issue it wouldn't matter what API im using.
 
Feb 21, 2021
10
0
10
0
final update: launched valheim again and the fps was normal but i was getting a horrible stutter every 2 seconds. i checked my frametimes and its jumping from 2ms to 2500 ms and the FPS graph is going from 2 fps to 85 every other tick. so im pretty sure my gpu is dying. thanks for the help though i appreciate it.
 

ASK THE COMMUNITY