• Find an incredible deal for Black Friday or Cyber Monday? Share those epic bargains with the community by posting them in this forum thread!

Question Why displayports of my zotac-gtx1070 doesn't work anymore?

Nov 17, 2019
4
0
10
0
Hello everyone,
I have a problem duplicating / extending windows10 on 2 Acer HA240Y monitors.
Everything was initially there. I have no idea what happened. Primary use video editing.

[Sorry in advance for grammatical errors, I've just g-translated this italian post. No one in Tom's.it can't say whats happen]

------------------------
PC:
AMD Ryzen 7 2700 Eight-Core Processor processor, 3200 Mhz
Graphics Name Zotac NVIDIA GeForce GTX 1070
PRIME B450-PLUS Motherboard
Installed Physical Memory (RAM) 16.0 GB
OS Microsoft Windows 10 Pro
BIOS Version / Date American Megatrends Inc. 1823, 10/15/2019
-----------------------


The gtx1070 has 1xHDMI and 3xDisplayPort outputs.
Both monitors WORK if connected HDMI> HDMI.
They both DO NOT work if I try to connect them to any of the 3 displayports of the video card (DisplayPort> HDMI).
The cable is brand new and testing it with the display of a laptop (Thinkpad x220) everything works, both monitors.


I don't know where to beat the head anymore ... the PC was assembled a year ago, still under warranty.


Proven solutions, but not effective:
  • clean uninstallation of nvidia drivers in safemod and reinstallation. anything
  • updated the bios. nada
  • power plan set to "high performance". nein
  • windows settings> display> multiple display> "detect". Reply = "Didn't detect another display". fk
  • updated any "device manager" entry ...

Before formatting everything and / or bringing it back to the store I would like to know if it is solvable ...


UPDATE:
Completely formatted the hard disk and clean installation of Windows 10. Installed motherboard and video card drivers.
The 1070 display port ports are NOT working yet. With none of the DP-HDMI cables. Like before...

I can only think that the 1070 failed exactly in all 3 dp ports. mh ...
 
Nov 17, 2019
4
0
10
0
Do you have a different DP cable to try using? If you only connect a single display to a DP port, does it work?
I bought a new dp-hdmi cable a few days ago.
This cable works if I attach it to a laptop (thinkpad x220) and to the monitor.
It does NOT work in any of the three 1070 displayports on the desktop computer.

I also tried turning off the PC, leaving only one monitor attached with the dp-hdmi cable, turned on the PC but the screen remains black.
Then I also tried the monitor's power cycle by disconnecting the power adapter from the screen, holding the power button for 5 seconds and reconnecting it. nothing ... :-(
 
Nov 17, 2019
4
0
10
0
Did the DisplayPort ports ever work? Have you experienced any power outages recently (since this problem started)?
Yes, all 3 displayports work up to a month ago.
I don't know if there were any power cuts in the night sincerely...

update:
I noticed right now that in the "Device Manager > Display Adapters" it appeared a "Microsoft Basic Display Adapter (no ACPI support)" with a "warning triangle".
If I click on "update driver" it tells me: "Windows was unable to install your Microsoft Basic Display Adapter (no ACPI support). If you know the manufacturer of your device, you can visit their website and check the support section for downloadable drivers."

Is it related to the issue?
 

ASK THE COMMUNITY

TRENDING THREADS