Question Why do CAPS & Num lock keys activate when I load Chromium-based web browsers?

IWTsNotGreen

Commendable
May 2, 2019
11
0
1,510
0
I started noticing this several months ago when loading Google Chrome for the first time in a session (not new tabs), and it's also happened with Edge & Opera (both Chromium-based), but not Firefox. Num lock comes on at the same instant.

This phenomenon doesn't actually create capital letters, so it's oddly non-functional. I just toggle off both keys each time, and they don't return until the browser is fully closed and reopened..

Thanks for any insights.

System: Windows 10 on a 2013 Toshiba i7 laptop. Nothing else wrong with it but the usual slowdowns with age and bloat.
 

Colif

Win 10 Master
Moderator
I guess you don't have one add on that runs on all 3?

Does it toggle their values to the opposite? Is it turning them on or off? Or either?

Try a clean boot and see if it changes anything - make sure to read instructions and make sure NOT to disable any microsoft services or windows won't load right - https://support.microsoft.com/en-au/help/929135/how-to-perform-a-clean-boot-in-windows

if clean boot fixes it, it shows its likely a startup program. You should, over a number of startups. restart the programs you stopped to isolate the one that is to blame.

it would be strange for one program to do all 3 but maybe

As it includes Edge it could be a feature of being merged into windows 10
 

IWTsNotGreen

Commendable
May 2, 2019
11
0
1,510
0
The only common add-on is SetupVPN, in Chrome and Edge, but this started long after that was installed. The computer is tightly set up with minimal background processes, but I'll look into those boot tests

All I have to do is press the Caps lock key twice to turn off both keyboard indicators. Unless it's some mysterious sign of a keylogger, it's mainly a curiosity that I figured others might deal with. I recall it starting in mid-2021 but didn't track details.
 

Ralston18

Titan
Moderator
Interesting:

Next time you boot the laptop, press the applicable key to access BIOS.

Check there for any defaults and options related to the CAPs lock and NUM lock keys.

Change, if possible, the POST process to be fully verbose and display what it is doing and the results of doing so.

If nothing apparent in POST then something being loaded at Start Up (Task Manager) may be setting the default values.
 

IWTsNotGreen

Commendable
May 2, 2019
11
0
1,510
0
FYI, this caps-lock phenomenon also happens when I open BlueStacks Android emulator, so it's more fundamental than just certain web browsers.
 

ASK THE COMMUNITY

TRENDING THREADS