Question Why do i only achieve 50-60-70FPS on Most games

Edmilsom

Honorable
Jun 4, 2015
124
0
10,680
0
So I am currently only achieving 70FPS on games like Hell Let Loose, I will put my specs below but i am wondering if this is normal/ to be expected or is this worth investigating more?

Specs
X470 - MB
2700x - CPU
650W PSU
3070 GPU
1440P Monitor
Trying to run at Max/High settings however even when i change to mid i see no difference in FPS - Why do i only achieve 70FPS here with lows of 35-40FPS?
 

boju

Titan
Ambassador
What speed is your ram at? Check with cpuz under memory tab. Memory speed will play a role since cpu determines amount of frames given to gpu. For Ryzen, two pairs of ram in dual channel at about 3000+ speed to get the most out of your chip. If you have high speed ram check xmp is enabled in bios.

What brand/model is your power supply?
 

DimkaTsv

Great
Nov 7, 2021
156
23
95
3
So I am currently only achieving 70FPS on games
Maybe you just got framerate limited by not fullscren mode and/or not fast sync on window (borderless) mode (which supposed to give 2*monitor FPS in games that doesn't use innate V-sync
What max FPS you monitor supposed to run?
 

Edmilsom

Honorable
Jun 4, 2015
124
0
10,680
0
What speed is your ram at? Check with cpuz under memory tab. Memory speed will play a role since cpu determines amount of frames given to gpu. For Ryzen, two pairs of ram in dual channel at about 3000+ speed to get the most out of your chip. If you have high speed ram check xmp is enabled in bios.

What brand/model is your power supply?

Power supply is a 550W RM Corsair
 

Edmilsom

Honorable
Jun 4, 2015
124
0
10,680
0
Maybe you just got framerate limited by not fullscren mode and/or not fast sync on window (borderless) mode (which supposed to give 2*monitor FPS in games that doesn't use innate V-sync
What max FPS you monitor supposed to run?
its a 165 HRZ monitor and no FPS limit in game - Fullscreen move all the time
 

Edmilsom

Honorable
Jun 4, 2015
124
0
10,680
0
Go run a userbenchamark and post the results here as a link. This will give us a decent idea of what is going on with what parts.
UserBenchmarks: Game 125%, Desk 88%, Work 121%
CPU: AMD Ryzen 7 2700X - 85.6%
GPU: Nvidia RTX 3070 - 143.7%
SSD: Kingston SSDNow UV400 240GB - 64.1%
SSD: WD Blue 3D SATA M.2 1TB - 59.2%
SSD: Samsung 860 Pro 1TB - 104.9%
HDD: WD WD10EUCX-63YZ1Y0 1TB - 47.2%
HDD: Toshiba P300 3TB - 95.3%
RAM: Corsair Vengeance LPX DDR4 3600 C18 2x16GB - 108%
MBD: MSI X470 GAMING PLUS




UserBenchmarks: Game 125%, Desk 88%, Work 121%
CPU: AMD Ryzen 7 2700X - 85.6%
GPU: Nvidia RTX 3070 - 143.7%
SSD: Kingston SSDNow UV400 240GB - 64.1%
SSD: WD Blue 3D SATA M.2 1TB - 59.2%
SSD: Samsung 860 Pro 1TB - 104.9%
HDD: WD WD10EUCX-63YZ1Y0 1TB - 47.2%
HDD: Toshiba P300 3TB - 95.3%
RAM: Corsair Vengeance LPX DDR4 3600 C18 2x16GB - 108%
MBD: MSI X470 GAMING PLUS
 

Edmilsom

Honorable
Jun 4, 2015
124
0
10,680
0
Can you upload a screenshot of cpuz memory tab. Userbench is reporting your 3600 ram clocked at 1800, double checking how the site is reading your ram as single or double rate.

im 98% sure its running at double rate so 3200 - cant upload a SC so what part of the memory section would you need confirmation on?
 
Last edited:

boju

Titan
Ambassador
That's fine, ram is running at 3600. Cpuz reads true clock so half of ddr, 1800 x2 = 3600. Userbench doesn't usually read sdr. Anyway, ram isn't the problem slowing cpu down.

Moving on to your storage situation. Im wondering if there's an issue there with lack of space for ssd with Windows on it to be efficient and userbench didn't register one of them. Can you experiment with only the 860 sata ssd connected and install Windows to it and whichever game and see if still have same problem?
 

Edmilsom

Honorable
Jun 4, 2015
124
0
10,680
0
That's fine, ram is running at 3600. Cpuz reads true clock so half of ddr, 1800 x2 = 3600. Userbench doesn't usually read sdr. Anyway, ram isn't the problem slowing cpu down.

Moving on to your storage situation. Im wondering if there's an issue there with lack of space for ssd with Windows on it to be efficient and userbench didn't register one of them. Can you experiment with only the 860 sata ssd connected and install Windows to it and whichever game and see if still have same problem?
Okay so storage issue fixed and getting much better scores there but still no FPS gain? :/

Should i be achieving more than 60 FPS on games like Hell let loose with this rig? its weird being on low or max settings doesn't give much FPS gain
 

boju

Titan
Ambassador
Vic 40 saw your bios version on userbench top right where it describes Windows version etc.

What did you do with storage?

Seems that game runs poorly for many from quick search i did. There are suggestions to improve performance like not running dx12.

Try running other games known to run well to compare with.
 

Karadjgne

Titan
Ambassador
Trying to run at Max/High settings however even when i change to mid i see no difference in FPS
That's a cpu issue. Not gpu. It means the cpu is only shipping 40-70 frames to the gpu, so no matter what the detail settings, gpu isn't working that hard to reproduce everything.

So something is using up cpu resources, or speeds, or computation ability. Could be anything from motherboard drivers out of date, driver conflicts with windows instructions, fclock not set, ram speeds, malware, Trojans, storage drivers etc. There's a lot of possible explanations.

The only thing you can do is start eliminating possibilities, such as updating bios to latest for your mobo, motherboard chipset drivers, cleaning out temp files, checking for malware, checking for driver conflicts in device manager, checking windows event viewer/history, checking services usage etc.
 
Reactions: helper800

ASK THE COMMUNITY

TRENDING THREADS