Why does empire total stop working when I do one specific thing?

Status
Not open for further replies.

Seattle_95

Honorable
Mar 7, 2012
6
0
10,510
I have got about 28 years into the total world campaign as Great Britain and every time I either declare war on Morocco or move any ships into the port in Gibraltar the game freezes and says: "Empire: Total War has stopped working". Any help or suggestions are appreciated.
 
Solution


I haven't played Empire for a while and when I was playing the game I would get bad lag but that was on my dell with a gt 220 card. Anyway you have to go through steam to play the game.

So try this if you haven't already done so. Go to Steam up in the top left hand corner left click on GAMES. Then...

DM186

Splendid
I have all the games of total war series. I also have had my share of problems. First off I need to see your spec's RAM, CPU, GPU, and PSU brand and how many watts it is etc. Once I get this info I will be able to help.

It sounds like it is a steam problem with the game. I had a problem like that in Shogun 2 I would get to a point in the game and it would freez up or crash to destop. To fix the problem I needed to adjust My GPU's.
 

Seattle_95

Honorable
Mar 7, 2012
6
0
10,510
Hey DM,

My specs are:

8GB RAM
640 GB Hard Drive
Intel Core i5-2430M CPU @ 2.40 GHz (4 CPUs), ~2.4GHz
HP Pavillion dv6
Battery/PSU is: 55Wh - 10.8 V
GPU: Intel HD Graphics (Memory: 1696 MB, Display Mode: 1366 x 768, Monitor: Generic PnP monitor)
Battery brand is hp notebook battery by nihon hewlett-packard.

It's a brand new laptop and I hope it's not a problem with that.

Thank you SOOO much for your help!
 
normally if it does it consistently at the same point in the game its either down to a corrupted save or a corrupted file needed to play that part of the game... if the game isn't patched to the latest version then do so.
check the integrity of the games files by copying them onto the hdd and extracting them from any archives available and manually moving and replacing existing files... this will often show a crc error if a file is corrupt, but may allow an install to continue without informing you theres an error... so replacing them 1 at a time may find the problem.

lastly if there is no visible errors in the files and your saves are correct then you will have to get in touch with the manufacturer. either by there forums or email... forums tend to be best as you can often find other users that have the same issue. but have either found a work around or can supply you with a patch.

 

DM186

Splendid


I haven't played Empire for a while and when I was playing the game I would get bad lag but that was on my dell with a gt 220 card. Anyway you have to go through steam to play the game.

So try this if you haven't already done so. Go to Steam up in the top left hand corner left click on GAMES. Then left click on View Games Library. This will bring up your games you have with Steam.

Now on Empire Tota War RIGHT click on it. Then left click on properties. Then left click on Local Files. Then click on Verify Integrity Game Cache. Then just wait untill it is done. Then try to play.

See if you can get past that point. It fails try the step one more time. If it fails again try what HEXit has suggested. I will say that guy knows his stuff and you can trust in what he is suggesting. Maybe you should try his first.

Well If we haven't defeated the problem then I will link you to the Total war web site and in there forums. I have had to use there forums before to help me with Shogun 2. Infact there are a lot of people on here that uses there forums.

Just scroll down when you first get there. Then you will see the Empire thread to start looking for your fix or you can post your own question. Good luck to you and let us know if anything has worked.

http://forums.totalwar.com/forum.php
 
Solution

Seattle_95

Honorable
Mar 7, 2012
6
0
10,510
I checked the integrity of the cache and it said it was fine, but it was still doing it. I still need to try what hexit said and then I will let you guys know. My friend in Montreal says I might need to reinstall it if all else fails.
 

DM186

Splendid


I had to reinstall Shogun 2, 3 times. Each time it took over 8 hours from steam. I don't have a hard disk. I had to buy it from Steam. So I would let it do its downloading over night and the next morning it would be done.

Three times 8 = 24 hours. So I know why you don't want to reinstall it plus you loose all of your progress in the game. It takes hours and hours to get through to where you are at in the game.

But since you know what to exspect you should go through it a little faster. Also on the integrity cache it should have down loaded some stuff. Anytime you crash to desk top you are suppose to do that.

Shogun 2 was my problem. Right after the realm devide it would do two things. It would just freeze or CTD (crash to desk top) But before that, in certain towns I would click on build army it would just freeze.

I would wait for 5 min and it would un freeze. I never did figure that one out and now I don't have any of those problems. I think there last patch for the game fixed it. But I did dial down my card from OC'd to stock.
 

Seattle_95

Honorable
Mar 7, 2012
6
0
10,510
Yeah, the main reason I'm so hesitant is because it seems like I've gone so far. Fortunately, my internet is pretty fast and it only takes an hour to reload. I tried what hexit said and it let me go about another 10 years and it started to act up again. I'll get it eventually.
 
Status
Not open for further replies.