Why does my 9500 Pro suck??

at_wits_end

Distinguished
Apr 2, 2003
2
0
18,510
0
I cannot get my ATI 9500 PRO to run any games without crashing or rebooting the system. I have uninstalled all old drivers and installed new ones. Dxdiag shows no problems. My sound card and vid card share an IRQ is this bad??
AThlon XP 2200
256mb DDR333
120gb HD
ATI Radeon 9500 PRO
SB Audigy2
 

Boco

Distinguished
Mar 26, 2003
38
0
18,530
0
Hmm. I know you said you updated your drivers, but did you get the new drivers for your chipset? I hear often that when people do it fixes the problem.
 

14Dx

Distinguished
May 5, 2002
160
0
18,680
0
Upgrading your chipset drivers, also updates the AGP driver which could be the problem. Having both cards on the same IRQ is bad. is the sounds card in the PCI slot right next the AGP slot? That would be why there on the same IRQ (if this is the case) so try moving it. Do you have the most recent ATI drivers (catalyst 3.2)? If none of this helps it could be a bad card. I've never had any problems with mine.

If its not broken, you're not trying hard enough.
 

BeerStore

Distinguished
Jun 4, 2002
82
0
18,630
0
i am running radeon9500 pro and it rocks.
first of all, what kind of mb?do u have the latest drivers for it?
My case: after removing my nvidia card , uninstalling the drivers and installing the radeon ,all went ok.But... some bird told me that when dealing with videocards, the best is to reinstall OS(like nvidia - ati)..surprise: after new OS was installed, all drivers up2date , i got a 50 fps+ boost in UnrealT.2k3
no irqs shared, no conflicts....100% rock stable, even with the most aggressive mem settings.
I am running an ASUS A7V266C, XP1800+, 512mb pc2100 Infineon, WD 60GB 8mb, radeon 9500pro 128 mb(bb ati),intel net, creative sb live.


<font color=green>my computer is a cheater...</font color=green>
 

JimmyDean

Distinguished
Mar 17, 2003
326
0
18,780
0
Well if the sound card and video card are sharing irq's then I dont think there is any way it could work right. Like if you tried to start UT2k3, it would request the video card but then it would try to request the sound card, or maybe it would happen the other way around but either way there is going to be a conflict. Can you change the IRQ of the sound card? Try and disable it in the hardware manager and try again. If it works then try to change the IRQ of the sound card

<b><font color=red>Remember kids, if you see a downed power line, suck on the end, candy comes out!</font color=red></b>
 

GeneticWeapon

Splendid
Jan 13, 2003
5,786
0
25,780
0
Old drivers left in system32......beleive....

My Score..<A HREF="http://service.futuremark.com/compare?2k1=6258104" target="_new">http://service.futuremark.com/compare?2k1=6258104</A>..Pic's of my pc before I pimped it.<A HREF="http://www.lochel.com/THGC/html/Genetic_Weapon.html" target="_new">http://www.lochel.com/THGC/html/Genetic_Weapon.html</A>
 

ASK THE COMMUNITY