Question Why does my GPU get 100% usage in CSGO

culzone

Reputable
Apr 27, 2016
517
0
4,990
3
I use a 2080 ti with watercooling and a i7 9700k 4.8ghz
and my GPU caps out on almost every map in csgo on 1080p low settings
(100% gpu usage) only uses 1gb VRAM
 

culzone

Reputable
Apr 27, 2016
517
0
4,990
3
Post the actual link to your results.

Also, what is the make and model of the power supply?
https://www.userbenchmark.com/UserRun/23588879
Sorry my bad guys I wrote 9700k and I actually have a 8700k, my mistake.
For the test i set the cpu at standard settings, my ram on XMP and the gpu on default settings.
To my knowledge there is nothing wrong with these results.
Invalid result on SSD is because it did not have 84gb of space which is required for that test. (got around 70gb)
 

culzone

Reputable
Apr 27, 2016
517
0
4,990
3
Before I had a 1070ti and i never got higher than 40% GPU usage in CSGO with that gpu since the game is not GPU demanding at all, with my 1080ti i got about the same (it did not even boost that's how little gpu demanding this game is) So.. how the hell does my 2080 ti get capped out like im playing 4k witcher 3? It does not even matter if i change the resolution to for example 1024x768 i still get capped out.
I also get upwards 50-70% CPU usage
 
Last edited:

Phaaze88

Dignified
Herald
https://www.userbenchmark.com/UserRun/23588879
Sorry my bad guys I wrote 9700k and I actually have a 8700k, my mistake.
For the test i set the cpu at standard settings, my ram on XMP and the gpu on default settings.
To my knowledge there is nothing wrong with these results.
Invalid result on SSD is because it did not have 84gb of space which is required for that test. (got around 70gb)
Yeah, nothing out of the ordinary there.

And it only behaves that way with CS:GO...
First time I've ever seen this... ok, Gpu-Z time.

Open Gpu-Z and post a screenshot of the Graphics Card tab.
Then run the game for 5-10mins with Gpu-Z open on the Sensors tab and take a quick screenshot of that.
Post through imgur.com or the like.
 
Reactions: culzone

culzone

Reputable
Apr 27, 2016
517
0
4,990
3
Yeah, nothing out of the ordinary there.

And it only behaves that way with CS:GO...
First time I've ever seen this... ok, Gpu-Z time.

Open Gpu-Z and post a screenshot of the Graphics Card tab.
Then run the game for 5-10mins with Gpu-Z open on the Sensors tab and take a quick screenshot of that.
Post through imgur.com or the like.
I just noticed in GPU-Z that my gpu runs at pci express x2 3.0 in the first slot for some reason.
I reseated the GPU and it's now running in x16 3.0! my gpu and cpu usage is back to normal and my fps aswell!
SOLVED! GPU-Z information <3<3<3<3
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS