[SOLVED] Why doesn't port-forwarding work ?

Dec 20, 2020
33
2
35
0
Warning in advance - I am not very tech-savvy and might be doing some basic things wrong.

Hello! I am trying to run an instance of Visual Studio Code in the browser using the open-source project code-server. For this, I am trying to port forward from private port 8080 on my Raspberry Pi 4 to my public port 8080. I logged into my NETGEAR Orbi RBR40 Router to try to configure this, which I'm pretty sure I did properly. However, when I go to check if the port is open using yougetsignal's port forwarding tester, it says that port 8080 is not open. I believe this issue is happening because I have an xFi Gateway modem and router combination. I'm using the NETGEAR Orbi RBR40 as the router, and the modem part of the xFi Gateway as the modem. However, I am not using bridge mode, the option that disables the router on the xFi Gateway, as there are some other devices that I am plugging directly into the xFi Gateway that use the separate network on the xFi Gateway router. Because of this, I'm not sure if the modem is forwarding the requests to the NETGEAR Orbi RBR40 router I am using at all, or if the router on the xFi Gateway is somehow blocking the port forward on the NETGEAR Orbi RBR40. Does anyone know what I should try next or what I am doing wrong? Thanks!
 

kanewolf

Titan
Moderator
Warning in advance - I am not very tech-savvy and might be doing some basic things wrong.

Hello! I am trying to run an instance of Visual Studio Code in the browser using the open-source project code-server. For this, I am trying to port forward from private port 8080 on my Raspberry Pi 4 to my public port 8080. I logged into my NETGEAR Orbi RBR40 Router to try to configure this, which I'm pretty sure I did properly. However, when I go to check if the port is open using yougetsignal's port forwarding tester, it says that port 8080 is not open. I believe this issue is happening because I have an xFi Gateway modem and router combination. I'm using the NETGEAR Orbi RBR40 as the router, and the modem part of the xFi Gateway as the modem. However, I am not using bridge mode, the option that disables the router on the xFi Gateway, as there are some other devices that I am plugging directly into the xFi Gateway that use the separate network on the xFi Gateway router. Because of this, I'm not sure if the modem is forwarding the requests to the NETGEAR Orbi RBR40 router I am using at all, or if the router on the xFi Gateway is somehow blocking the port forward on the NETGEAR Orbi RBR40. Does anyone know what I should try next or what I am doing wrong? Thanks!
You first need to verify that you have a public IP address. Compare the value shown here -- https://whatsmyip.com/ with the WAN status page in your router. If the WAN IP address doesn't match then you can't port forward.
 

kanewolf

Titan
Moderator
Warning in advance - I am not very tech-savvy and might be doing some basic things wrong.

Hello! I am trying to run an instance of Visual Studio Code in the browser using the open-source project code-server. For this, I am trying to port forward from private port 8080 on my Raspberry Pi 4 to my public port 8080. I logged into my NETGEAR Orbi RBR40 Router to try to configure this, which I'm pretty sure I did properly. However, when I go to check if the port is open using yougetsignal's port forwarding tester, it says that port 8080 is not open. I believe this issue is happening because I have an xFi Gateway modem and router combination. I'm using the NETGEAR Orbi RBR40 as the router, and the modem part of the xFi Gateway as the modem. However, I am not using bridge mode, the option that disables the router on the xFi Gateway, as there are some other devices that I am plugging directly into the xFi Gateway that use the separate network on the xFi Gateway router. Because of this, I'm not sure if the modem is forwarding the requests to the NETGEAR Orbi RBR40 router I am using at all, or if the router on the xFi Gateway is somehow blocking the port forward on the NETGEAR Orbi RBR40. Does anyone know what I should try next or what I am doing wrong? Thanks!
You first need to verify that you have a public IP address. Compare the value shown here -- https://whatsmyip.com/ with the WAN status page in your router. If the WAN IP address doesn't match then you can't port forward.
 
May 16, 2021
10
0
20
1
Ok, got it. How do I check the WAN IP address of my router? I can't seem to find it. Are there any other names that the WAN IP would be called?
I dont know how does your interface look but for me its:

GATEWAY > NETWORK > WAN and check the IPv4 address there, its probably the first ip. And then go to google and search my ip and compare the ip addresses. If they are not the same then you are behind a NAT or a CGNAT.
 

ASK THE COMMUNITY

TRENDING THREADS