Question Why is BIOS mode set to Legacy?

May 15, 2019
3
0
10
0
Hi everyone, long time lurker and first time poster here.

I recently built a new computer for myself. I think the only specs that matter for my question are these:
  • MOBO: MSI MPG Z390 Gaming Pro Carbon AC
  • OS: Windows 10 64bit on 500GB Samsung 970 Evo PLUS M.2 PCIe SSD
When I was installing Windows 10 I am pretty sure I set the storage boot option control to UEFI. I then did these checks to see that I do indeed have UEFI BIOS:
  • I can see Secure Boot and Fast Boot options in BIOS
  • In Disk Management I can see EFI system partition
  • System Information says BIOS mode is UEFI
My question…why does my BIOS say that BIOS mode is Legacy? See here: View: https://i.imgur.com/31apTXu.jpg
and notice how Legacy is highlighted. Is that a bug? It’s actually really bugging me! I did search around but couldn’t find anything to address my question. Thanks for any and all input.
 
May 15, 2019
3
0
10
0
Setup Mode switch - press this tab or the F7 key to switch between Advanced mode and EZ mode.
Are you saying EZ Mode = Legacy BIOS Mode, and Advanced Mode = UEFI BIOS Mode? If yes then I thought about this too, but couldn't find anything to confirm this. Did you read about it somewhere or is it a guess?
 
May 15, 2019
3
0
10
0
It means both UEFI and legacy boot options are enabled. Could be also Legacy mode is tried first, then UEFI mode.
Anyway - nothing to worry about.
If that bothers you so much, you can disable legacy boot mode altogether.
I checked and see I have 2 boot modes available. 'UEFI' and 'Legacy + UEFI'. It has been set to UEFI all along. Yeah it does sort of bother me, it's like a thorn. I just want everything to be set up perfectly.
 

Similar threads


ASK THE COMMUNITY

TRENDING THREADS