Question Why is my BRAND NEW RX590 Benchmarking so low

Feb 19, 2020
4
0
10
0
https://www.userbenchmark.com/UserRun/24781538#GRAPHICS_CARD

So thats the benchmark for my pc, I just installed the GPU and the SSD yesterday. I have no idea why my GPU is struggling so much here running at only 59%! Any suggestions as to why it is so low and how to fix it? I am using Windows 7 64bit. Should I be taking the gpu back or something? I am pretty new to this, asking for help, cheers.
p.s Motherboard is a P8Z77-v lx
 

MadsModsat

Prominent
Oct 10, 2019
543
99
540
33
It says you have very high background process CPU usage, above 50%.

If that's right, it may impact the performance of your system during the benchmark, and maybe in-game performance.

But as AngelTech suggested, look at what your real world in-game performance is, it will give you a better idea of how your PC is actually performing.
 
Feb 19, 2020
4
0
10
0
It says you have very high background process CPU usage, above 50%.

If that's right, it may impact the performance of your system during the benchmark, and maybe in-game performance.

But as AngelTech suggested, look at what your real world in-game performance is, it will give you a better idea of how your PC is actually performing.
Thanks, I redid the benchmark without anything running and got the same results unfortunately. I believe my FPS is lower than it should be in game’s and the card is constantly running at 100% on each game I try (cpu not even at 70-80%)
 
Jan 4, 2020
23
1
15
0
I'd complement the answers suggesting a custom fan curve, I have a RX 580, they're hot, and the stock fan curve isn't enough to keep up with the card power draw.
Always look in the temperatures, if is reaching 80 °C, it'll start to throttle back, and they will show 100% or close of utilization
 
Feb 19, 2020
4
0
10
0
I'd complement the answers suggesting a custom fan curve, I have a RX 580, they're hot, and the stock fan curve isn't enough to keep up with the card power draw.
Always look in the temperatures, if is reaching 80 °C, it'll start to throttle back, and they will show 100% or close of utilization
Will only hit around 50-60 at 100%, but it runs at 100% for pretty much any game I play, I don’t know if that’s normal or not sorry
 

ASK THE COMMUNITY

TRENDING THREADS