Why is my GeForce Experience opening but not showing anything?

Ramlethal

Estimable
Dec 21, 2016
888
0
2,710
268
Before doing everything we need to check some basics:

1- Secure your Firewall / Anti-virus are Unabled
2- Set Geforce Experience to be open as Administrator (by clicking propieties, launching options on the Gforce experience .exe)
3- What internet Explorer version do you exactly have? I kinda suspect that you are using a way too old version or you dont have java or any browsing components and thats the reason its not showing anything.
 
Aug 22, 2018
16
0
10
0


1. Im only using windows defender I already tried it on and off even my firewall is ok
2. I already run it as an admin still to no avail
3. Im sorry I didnt mention this, but Im using windows 10 and on 1803 update (cant update to 1809 since they pulled it out) so Im using edge and no internet explorer
 

Ramlethal

Estimable
Dec 21, 2016
888
0
2,710
268


I quite suspect that could just be the problem... Lets try by installing Google Chrome (or atleast thats the browser i have on my own PC), then just in case... Download the lastest version of Java https://www.java.com/es/download/
Reboot the PC and see what happends.
If nothing happends, you can just uninstall the Chrome and lets try keep looking at this...
Btw, are you using a Proxy or VPN to connect to internet?
 
Aug 22, 2018
16
0
10
0


Ok ill try installing the Java, nope I am not connected to any vpn or proxy

EDIT: Still not working after java install sigh..
 

ASK THE COMMUNITY

TRENDING THREADS