Question Why is my laptop going crazy? ( weird core frequency / hot )

May 28, 2020
2
0
10
0
I've been using my laptop ( i7-8550U / Nvidia MX150 / 8 GB RAM ) for gaming and other things for almost a year with power option set on "Balanced". Recently, I noticed that the laptop is getting so hot (100 C but games' performance was still fine). I decided to open it and clean the fan and I did that ( was a bit dusty tho). After cleaning and reopening the laptop, I noticed that fps in games fell off noticeably before I figured out the Turbo Boost is not working ( working on 1.8 GHz). I also noticed a super weird thing that I have never seen before ( On "Balanced" option, the processor is running on 3.7 - 3.9 GHz when I am not doing anything but once I start a game or the stress test , the frequency immediately turns to be 1.8 without even fluctuating around that number, and immediately goes up to 3.8 again at the moment I close the game or the stress test ). I also noticed that temperature reaches 100C ( while using chrome ) and I hear a loud sound coming out from the fan but with a warm air coming of the vents. I thought that the fan might not be connected to the heat sink properly so I reopened it and tried to tighten the nails and make sure that its properly installed, but nothing was changed.
I consider changing the thermal paste in a couple of days but I am not sure if its gonna help.
Does anyone know what causes this and what I should do ?
 

Vyrvelata

Upstanding
May 19, 2020
364
53
340
25
Go into your power plan and see if your power plan, is set to minimum processor state 5%



About your CPU clock speeds


Performance
  • # of Cores4
  • # of Threads8
  • Processor Base Frequency1.80 GHz
  • Max Turbo Frequency4.00 GHz
Your Base Frequency is 1.8GHz so it normal in stress test to be at 1.8 (stress test uses all cores).

Max Turbo is at 4GHz is ONLY IF ONE CORE IS IN USE!
Which is happening when you're browsing...in chrome and in normal windows workloads your cpu uses 1 of its cores!

When it starts to Use more cores it downclocks the speed (3.9-3.7 and lower untill 1.8), because if 4 cores are runing at 4GHz you will need computer power supply (not that tiny shiny brick you connect to your laptop to), and also you will need Big CPU tower with 120mm FAN poping out of your laptop to cool the CPU down.
Its normal while stressing all 4 cores to be 1.8GHz!

If before you didn't pay attention and saw, that's the case since you bought it, it doesn't mean now something changed, everything is working as intended
 
May 28, 2020
2
0
10
0
Go into your power plan and see if your power plan, is set to minimum processor state 5%



About your CPU clock speeds


Performance
  • # of Cores4
  • # of Threads8
  • Processor Base Frequency1.80 GHz
  • Max Turbo Frequency4.00 GHz
Your Base Frequency is 1.8GHz so it normal in stress test to be at 1.8 (stress test uses all cores).

Max Turbo is at 4GHz is ONLY IF ONE CORE IS IN USE!
Which is happening when you're browsing...in chrome and in normal windows workloads your cpu uses 1 of its cores!

When it starts to Use more cores it downclocks the speed, because if 4 cores are runing at 4GHz you will need computer power supply (not that tiny shiny brick you connect to your laptop to), and also you will need Big CPU tower with 120mm FAN poping out of your laptop to cool the CPU down.
Its normal while stressing all 4 cores to be 1.8GHz!
What makes me wonder is that I used to have the same everything before opening it for cleaning ( now I am having terrible FPS in game after have a good one before on the same settings. Also, the processor is running on ( 4 GHz - one core ) when I am doing nothing, but whenever I start the games I used to play it immediately falls to ( 1.8 - one core ), which cases lag.
  • I feel like something is preventing the processor to use more cores or to use Turbo Boost
  • 100C without using anything except chrome is weird too tho.
 

Vyrvelata

Upstanding
May 19, 2020
364
53
340
25
Also, the processor is running on ( 4 GHz - one core ) when I am doing nothing, but whenever I start the games I used to play it immediately falls to ( 1.8 - one core ), which cases lag.
  • I feel like something is preventing the processor to use more cores or to use Turbo Boost
  • 100C without using anything except chrome is weird too tho.
Your cpu is thermal throttling nothing weird about it too, you just didn't assemble properly your laptop, maybe you cleaned your thermal compound? (also do not tighten the screws of the cpu cooling too much! it should be normaly tight, not forced, just normal hand motion)
 

ASK THE COMMUNITY

TRENDING THREADS