Question Why is my microphone input is glitched ?

vedant.naik09

Reputable
Mar 14, 2018
8
0
4,510
0
Hello,
So recently I noticed that my microphone input was not working properly. I have realtek drivers installed and updated to the latest version. I will explain my problem in two cases:

Case 1: When I am using discord and turn on noise suppression, discord doesn't detect anything from my mic but it works properly when the noise suppressoin is on.. I can confirm that there is no noise from my mic and it is not cancelling the input completely. Also when the noise suppression is off and I watch any stream on discord then again discord doesn't detect anything from my mic but when I stop watching the stream it seems to work again..But its not just about discord, because when I used an android emulator called noxplayer this same issue exists. My conclusion from this is that there is a problem applying enhancements to my mic, so in case of discord noise suppression doesn't work, and it probably applies echo cancellation while watching the stream so my mic input glitches again..In case of the emulator I reckon there is some inbuilt noise cancellation installed.. How do I fix this guys??

Case 2: I turn on the noise cancelling from the realtek settings itself and I can see the input in windows settings but it wont detect any output anywhere else..

What I have tried so far:

  • Reinstalled Windows
  • Reinstalled the drivers for realtek
  • Rolled back the drivers
  • Checked the privacy settings in Windows
I am on windows 10 20h2, I have even tried rolling back to the previous versions..

None of these have seemed to work..Please help me find a solution..Any help will be appreciated
 
Last edited by a moderator:

ASK THE COMMUNITY

TRENDING THREADS