Question Why is my pc crashing after exiting a game?

Aug 6, 2022
4
0
10
0
Ive been having an issue this past week where after exiting a game, my pc will generally crash if had the game open for over an hour. As soon as i exit to my desk top it seems to crash. When i check back in event manager it just says there was a kernal error which was non specific and wouldnt give an error code. Im convinced its my ssd dying as its quite old now as when ive tried deleting thing off the drive it has also crashed. Is it time to change out my boot drive?
Im running on the newest update of windows 11
i7 10700k stock frequencies about a year old
Rtx 2060 3 years old
32gb 3600mhz ram 2-3 months old
650w psu 3.5 years old
Boot drive is a 120gb wd green and is about 90% of the way full 3.5 years old
And 2 of other drives ones a 500gb samsung nvme ssd and is about 70% full not sure on the age as i had it used and the other is a 2tb segate baracuda which is 20% full and had it 2 years
 
Last edited:

Ralston18

Titan
Moderator
Update your post to include full system hardware specs and OS information.

Include PSU: make, model, wattage, age, condition (original to build, new, refurbished, used)?

Disk drive(s): Make, model, capacity, how full?

Which Kernal Error number?

Also look in Reliability History.
 
Reactions: Lemmy37
Aug 6, 2022
4
0
10
0
Update:
My pc now refuses to boot i get no error codes,no cpu fans spining no nothing. Does this mean my motherboard has died?
 
Aug 6, 2022
4
0
10
0
So ive been having random pc crashes for the past week where in, some of my usb devices will no longer be recognised and then the pc would randomly restart. At first i thought nothing of it and it just being a one time thing, but its been every day this week. I eventually suspected that it could be my boot ssd as its quite old and has been giving me issues for quite a while now. But following what has happend today im now suspecting the worse. My pc now refuses to post and there are no led indicators on the motherboard showing the boot process. Some of it seems to be working and it is definately recieving power, as the exhaust fan works and so do the leds. However the pump for the aio and fans for it no longer work and it has no rear usb power. The restart button also does nothing. Any ideas on what could have died
Im running windows 11
Cpu: i7-10700k
Mobo: asus prime z490-A
Ram: 32gb corsair vengance rgb pro
Gpu: msi rtx 2060
Boot Ssd: wd green 128gb sata roughly 90% full
Psu: corsair tx650 ( i did check that my pc is under the recomended wattage)
 

Ralston18

Titan
Moderator
I see two immediate concerns:

1) 650w psu 3.5 years old

History of heavy use for gaming, video editing, or even bi-mining?


2) Boot drive is a 120gb wd green and is about 90% of the way full 3.5 years old

Personally I prefer and recommend that any disk drive be less than 70-80% full. That is just me and there may be other preferences suggested.

Refusing to boot: try booting into Safe Mode.
 
Aug 6, 2022
4
0
10
0
I see two immediate concerns:

1) 650w psu 3.5 years old

History of heavy use for gaming, video editing, or even bi-mining?


2) Boot drive is a 120gb wd green and is about 90% of the way full 3.5 years old

Personally I prefer and recommend that any disk drive be less than 70-80% full. That is just me and there may be other preferences suggested.

Refusing to boot: try booting into Safe Mode.
Heres the issue, i cant even get to the bios, like some of the fans turn on but the bios screen wont flash up at all
 

Ralston18

Titan
Moderator
Things you can do:

Try a new CMOS battery as a matter of elimination.

Power down, unplug, open the case.

Clean out dust and debris.

Swap in the new CMOS battery.

Verify by sight and feel that all connections, cards, RAM, jumpers, and case connectors are fully and firmly in place.

If the system still does not boot, try booting into safe mode.

Failing all that do you have access to another PSU to install for testing purposes?
 

ASK THE COMMUNITY