Question Why is my PC lagging in normal usage ?

Dominikm

Prominent
May 9, 2019
16
0
510
0
Hi all,

I'm hoping someone can help me with lag on Windows 10. I built a new desktop last month. Ryzen 5 3600 3.6Ghz with G Skill Trident NEO 16GB Ram and Samsung Evo 970 NMVE. I only use it for work at home. I do websites and SEO. So I don't have heavy use. Probally over the top for what I need and a little wasted money but I'm happy as it's fast.

Anyhow, I get lag. Sometimes I'll be working away and when I type there is lag. It's really bad. A 5 second or longer wait. Or when I go to another window in Chrome or pull up the some folders it just wont load. Then after 15 seconds it all happens at once in hyperspeed.

Any advice what could be causing this? The setup is very fast and I get windows can get clogged up over time but this shouldn't be an issue with a new build like this. I look after it also with CCleaner run on start up automatically and evey week I'm doing my virus scans plus windows defener is always working. Normally my CPU is not doing more than 5% if I check the task manager. Memory never about 40% or so. Disk never above 5% to 10%.

So I'm lost. As this shouldn't be happening at all.

Any advice?
 

Dominikm

Prominent
May 9, 2019
16
0
510
0
what the motherboard? gpu?
brand and model of the psu?
how full is the ssd?
cpu/gpu temp?
Thanks for helping.

This is the complete build:
AMD Ryzen 5 3600 3.6Ghz
G Skill Trident NEO 2x 8GB
Samsung Evo 970 500GB
Corsair 850W RM850 (80+ Gold)
ASROCK B450 Steel Legend Motherboard
MSI GTI 1030 Aero ITX 2GD5 OC
Corsair iCue 4000x Case - 3 font fans
Be Quiet Pure Rock 2 CPU Fan
23.8 Acer IPS Monitor

The SSD is not full at all. The C drive has 123GB with 47GB free. The rest is for the D drive thas has 289GBb or 341GB free.

When I check task maanger it tells me the GPU is 33 degrees Celcius.

I downloaded Core Temp and after watching it for a little bit I see that it jumped between 44 and 51 degrees when idling. When I loaded up 20 things at once it went to about 65 and then stays at around 55 to 60.



Does this help?
 

Dominikm

Prominent
May 9, 2019
16
0
510
0
Ram - 3200MHz (from task manager performance tab and this is what I should be I believe)
Bios - P3.40 - 6/4/2020 (I checked with CPU-Z)
Windows - Yes, I bought Windows 10 when I got the shop to build it. So fresh install. Two months now actually looking at the date and I also followed along a bunch of videos pn YouTube to speed things up as I've always had slower laptops in the past so I figured it will only help and it did make things faster.
 

Dominikm

Prominent
May 9, 2019
16
0
510
0
using the AMD performance power profile?
windows 10 up to date? I remember reading they MS fixed some scheduling issue.
I'm using the AMD Ryzen High Performance power plan. I figured that's specific to the CPU I have so it's a good one to use.

Windows 10 is up to date. There have been a few updates I've been though since this started.
 

Dominikm

Prominent
May 9, 2019
16
0
510
0
@rgd1101 I had a wireless keyboard. I got so annoyed with this I took my girls keyboard that's wired.

The issue magically vanished 🆒

Maybe that's the first question to ask if this comes up again in the forum hehe :rolleyes::LOL::ROFLMAO:

Thanks for all your help with this though.
 

ASK THE COMMUNITY

TRENDING THREADS