Why is my stream Lagging when I can see it normal

Adrian_30

Distinguished
Jul 6, 2011
7
0
18,510
0
I have upgraded my computer with all new hardware and trying to stream in 5760 x 1080 instead of 1920 x 1080. I have three monitors and have use AMD Eyfinity in the past but now I have a NVIDIA GeForce GTX 1070 8 GB graphics card.
The processor is an Intel Core i7 - 8700K Coffee Lake 6-Core 3.7 GHz.
The ram is Corsair Vengeance LPX 32 GB (4 x 8 GB) DDR4 3000 MHz C15 XMP 2.0 and motherboard is ASUS ROG Maximus X Code Socket 1151/Z370.
My montors are 3 x BenQ GL2250H (1920x1080 @ 60Hz) with a Samsung SSD 840 EVO 1TB, 931GB and Corsair HX850i ATX/EPS 850W Platinum Series power supply so you can see I have a good computer from the specs.

Now onto the OBS output settings that are Video Bitrate = 4000.
Encoder = software x264.
The Video setting are Base resalution 1920 x 1080.
Output + 1920 x 1080.
Common FPS values = 60.
This has me scratching my head as to why it lags in 5760 x 1080.
If I use one monitor for gaming theirs no lagging in the stream.
My Download speed is 110 Mbps and Upload is 6 Mbps so upload is adequate enough for streaming.
What I do not understand is how a lot I see on YouTube are stream perfectly in 5760 x 1080 with in gaming or without in gaming and just cameras I have tried both and still get lagging I even lower my game setting to the lowest and it still lagged I also lower the video bit rate to 3000 and 2500 like a few suggested and even that made no difference.
I know it not the graphics card because the games run smooth and when I view the stream on the laptop its lagging like mad.
I also did recordings with OBS with MP4 and not FLV so I could play them back and guess the play back showed the game lagging just like I see in the streams.
I have no idea as to why or what is causing my stream to lag.
My old computer had a AMD FX-8350 processor with 32.0GB Dual-Channel DDR3 2600mhz ram and a 4096MB ATI AMD Radeon R9 380 4GB Series graphics card so you can see a big difference there.
The only possible cause I think is that the graphics card now being a 8GB is put more strain on the processor but as me confused when others have a 11GB graphics card and there stream is smooth with no lagging.
I have pasted to links from my stream from last year with the old computer and one stream with the new computer.
Some have tried to tell me its my internet upload but I know it is not. I have tried all different settings but nothing seems to work.
If any knows what causing this and how to cure it it would be appreciated.

17 May 2018
https://youtu.be/nRMRTjMS7VU

7 February 2019
https://youtu.be/XEg0p54DozA
 

Similar threads


ASK THE COMMUNITY

TRENDING THREADS