Question Why is ONLY my PC losing connection to Specific websites regularly?

Nov 8, 2018
2
0
10
0
This has been happening for the past month or two and I can't find any post describing the same problem. It is only my computer, which I built over a year ago, that is affected, and it lasts about 2-3 minutes. All the websites that I know I loose connection to are steamcommunity.com , Battle.net, Discord, Reddit, and tomshardware, which I only realized just now when I tried connecting during another 2-3 minute semi-blackout. I have not tested this extensively, but these are the only sites I know of that get affected and only on my PC. To be as clear as possible, I can connect to all these sites on my phone and tablet just fine, and my PC's connection to other websites like YouTube is not slowed down and I have no programs managing my network in any way as far as I know.

PC Specs (please don't reply with what you think of my build or what I could've done better)

CPU: Ryzen 5 2400G (has updated drivers)

GPU: EVGA GTX 1060 3G (has updated drivers)

MOBO: MSI B350M PRO VDH

RAM: Patriot Memory Viper Elite Series DDR4 16GB 2400MHz (single channel)

WiFi Card: TP-Link AC1200 PCIe Wireless Wifi Card (has updated drivers)

Just ask if you need to know anything I forgot to mention.
 

Ralston18

Titan
Moderator
What make and model router do you have?

The router's logs, if available and enabled, may provide some clue.

Who has admin rights to your router?

Are you able to run and post the results of "ipconfig /all" via the Command Prompt on your computer?
 

ASK THE COMMUNITY

TRENDING THREADS