Question Why isnt my hdd or optane memory recognised?

Captain Morgan17

Commendable
Jul 15, 2017
33
0
1,530
0
https://ibb.co/wzgQC3f
https://ibb.co/gd8RkKY

I posted 4 images to show what the programme says^
As you can see from the 3rd Picture, only my SSD is recognised


I have recently lost the use of my HDD and optane memory it happened randomly lastnight my pc doesnt see my HDD but the ''Intel Rapid Storage technology'' programme recognises it. i tried to fix it and ended up wiping the drive completely i would really appreciate any help to fix this issue with my HDD and Optane memory.
 

popatim

Titan
Moderator
Yep, its fubar. Assuming you want to have Optane with the HDD then it's approximately like this:

Backup the data on the drives if you need it.
split the raid 1 if it was done in the bios or raid bios (Ctrl+i at boot),
shutdown & unplug,
disconnect the HDD & remove the optane.
power backup and install the OS to the SSD.
install your motherboard drives including intel RST (this is usually listed as your Sata driver)
shutdown & unplug.
install the optane and connect the HDD back up
boot the pc back up.
enter iRST & enable Optane, linking it to the HDD.
 

Captain Morgan17

Commendable
Jul 15, 2017
33
0
1,530
0
Yep, its fubar. Assuming you want to have Optane with the HDD then it's approximately like this:

Backup the data on the drives if you need it.
split the raid 1 if it was done in the bios or raid bios (Ctrl+i at boot),
shutdown & unplug,
disconnect the HDD & remove the optane.
power backup and install the OS to the SSD.
install your motherboard drives including intel RST (this is usually listed as your Sata driver)
shutdown & unplug.
install the optane and connect the HDD back up
boot the pc back up.
enter iRST & enable Optane, linking it to the HDD.
What does ''Split the raid 1'' mean? the OS is already installed to the SSD,
 

popatim

Titan
Moderator
What does ''Split the raid 1'' mean? the OS is already installed to the SSD,

Your OS is installed to the Raid array.
Look at your Image # 1, on the right side you'll see that you created a raid array with your SSD and HDD. Since the controller now has to rejoin the two halves of the data , you've reduced the speed of the SSD to a match the HDD. As well as lost nearly 700GB of space on it. This is why your 1TB drive doesn't show up in image# 3.

I should have said 'split the raid 0' , not raid1.
 

Captain Morgan17

Commendable
Jul 15, 2017
33
0
1,530
0
Your OS is installed to the Raid array.
Look at your Image # 1, on the right side you'll see that you created a raid array with your SSD and HDD. Since the controller now has to rejoin the two halves of the data , you've reduced the speed of the SSD to a match the HDD. As well as lost nearly 700GB of space on it. This is why your 1TB drive doesn't show up in image# 3.

I should have said 'split the raid 0' , not raid1.
Oh yea im not tec savvy at all, so how do i remove this raid then and revert it back to its normal SDD and HDD + optane combo When i click the raid thing in the programme it doesnt give me an option anywhere to remove it?
 

Captain Morgan17

Commendable
Jul 15, 2017
33
0
1,530
0
Your OS is installed to the Raid array.
Look at your Image # 1, on the right side you'll see that you created a raid array with your SSD and HDD. Since the controller now has to rejoin the two halves of the data , you've reduced the speed of the SSD to a match the HDD. As well as lost nearly 700GB of space on it. This is why your 1TB drive doesn't show up in image# 3.

I should have said 'split the raid 0' , not raid1.
Just a further note, i created this ''raid'' only 2 days ago or so, before that the SSD was the only thing the OS was installed on. I was just pressing buttons trying to renable my HDD and optane but in my ignorance i only made things worse.
 

Captain Morgan17

Commendable
Jul 15, 2017
33
0
1,530
0
Can we get screenshots of you disk management and iRST screens again please?
https://ibb.co/qmxHPXg
https://ibb.co/CP62MTw

In the second image, the second drop down menu when enabling the optane the only option it gives me is my SSD when its my HDD i want to add the optane too ofc. any help would be appreciated. Also i dont know if this is relateable to anything but my PC sometimes freezes for like 5 secs at random moments.
 

popatim

Titan
Moderator
Looks much better now! Thanks!
In Disk Managemet. Right click on the Hdd's partition (right side in lower section, where it says Games D: ) and then select Shrink Partition. Free up about 10-20mb of space. It doesnt have to be accurate. I usually just leave around 100mb in the few I've set up.
Optane needs a little bit of unallocated space at the very end of the drive to be able to accelerate it.
 

Captain Morgan17

Commendable
Jul 15, 2017
33
0
1,530
0
Looks much better now! Thanks!
In Disk Managemet. Right click on the Hdd's partition (right side in lower section, where it says Games D: ) and then select Shrink Partition. Free up about 10-20mb of space. It doesnt have to be accurate. I usually just leave around 100mb in the few I've set up.
Optane needs a little bit of unallocated space at the very end of the drive to be able to accelerate it.
Thanks for the reply, erm after shrinking the volume by 30mb the HDD still didnt appear in the drop down menu like in image2. So just for a test i shrinked it by 300mb and still it doesnt appear in the options for the optane. Any suggestions?
 

Captain Morgan17

Commendable
Jul 15, 2017
33
0
1,530
0
Which motherbd do you have?
On some you have to set the sata ports to iRST with Optane (AsRock/Asus/Gigabyte) or Raid/Optane (MSi) for the Sata port mode type.
Asus PRIME Z370-P is my motherboard how do i set the sata ports to IRST? im guessing i have to go to the bios?


Edit: I went into Bios and it says sata mode is already IRST controlled. not sure though if thats what you were referring to.
 
Last edited:

Captain Morgan17

Commendable
Jul 15, 2017
33
0
1,530
0
I've seen Intel RST with Optane . Looking at your manual, your choices are AHCI or 'Intel RST with Optane System Acceleration' so I think you have it right.

You may have to update your Bios to support the newer version of Optane.
https://www.asus.com/us/Motherboards/PRIME-Z370-P/HelpDesk_BIOS/
You also may have to have it (HDD) on Sata port 1 or 2.
Sorry for the delay in response, i had to go and buy a usb flash drive. So i have updated the bios finally to the latest version, and made sure the settings were the same as before in bios e.g IRST controlled and enabled sata 2 hot plug but still in the IRST programme its not showing the HDD in the drop down menu.
 

ASK THE COMMUNITY

TRENDING THREADS